在Cisco1700系列上实现PPPOE+NAT

1/6/2008来源:Cisco网络人气:3376

硬件要求,最低 cisco1720系列,8M Flash 32M Memory 以及WIC-1ENET模块和普通ADSL猫 就可实现拨号上网。
IOS要求12.2-4 XL5
配置如下:
ip subnet-zero
ip name-server 202.106.196.115
!
vpdn enable
!
vpdn-group PPPoE
request-dialin
PRotocol pppoe
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Ethernet0
no ip address
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
mtu 1492
ip tcp adjust-mss 1452
ip address negotiated
ip nat outside
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap chap callin
ppp pap sent-username xxxxxxx passWord xxxx
ppp chap hostname xxxxxx
ppp chap password xxxx
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
end