Catalyst 5509 ATM 调试报告

1/6/2008来源:Cisco网络人气:3281


  注:虚网名指LANE NAME
  
  1)系统的安排。
  
  一个ATM环境中必须有ATM-SWITCH和必要的连线,5509 现在的三个基本模块,CONSLE、ATM光纤、以太网。
  
  2)调试步骤
  
  
  
  安排一个LECS 、一个LES。LECS在ATM-SWITCH上,在ATM-SWITCH上有缺省的ATM前缀,首先确定所有的ATM地址,记录后可以再对要更改的设置(如前缀)进行更改。
  
  
  
  A 加LECS的地址,设置BUS的ATM接口后绑虚网名,在LECS上做数据库(起名),把BUS的虚网名绑在LES的ATM地址上,设置系统的缺省虚网名。 给LECS 定ATM口 (如 ...atm0.*)起LECS的名字,把刚才做的库名绑在LECS上。
  
  
  
  B 为备份做的预备设置第二个LECS地址,在备份机器上。把虚网名对应上LES的地址。
  
  
  
  C 在客户状态的机器上,设置ATM口号 把相应的以太网号和做出的虚网名一一对应设出。
  
  
  
  5509上的一些监控命令:
  
  
  
  SH LOG 检查设备的日志;SH VTP STA 检查设备的VLAN的状况;SESS X 到要去的模块;SH LANE 看设备的ATM工作状态;PING ip检查设备连接。 
  
  5509上设置:
  
  
  
  set snmp community read-only public
  
  set snmp community read-only public
  
  set snmp community read-write PRivate
  
  set snmp community read-write-all secret
  
  set snmp rmon 让设备可以被CISCO VIEW 监控
  
  set interface sc0 1 172.16.1.230 255.255.255.0 172.16.1.255 分配设备IP
  
  set spantree portfast 登录快速for PC
  
  sh config 看配置
  
  hostname test 给设备起名字
  
  enable passWord xxxxx EN加口令
  
  interface Ethernet0
  
  interface ATM0 进入ATM0口
  
  atm preferred phy A
  
  atm pvc 1 0 5 qsaal
  
  atm pvc 2 0 16 ilmi
  
  lane auto-config-atm-address
  
  interface ATM0.1 multipoint
  
  lane client ethernet 1 default使以太模块绑到ATM的LANE上 
  
  interface ATM0.3 multipoint
  
  lane client ethernet 3 wewew
  
  line con 0
  
  line vty 0 4 进入VTY 0 4
  
  password xxxx 设置口令
  
  以上一段是ATM模块的配置中典型的部分。
  
  enable password sss
  
  ip subnet-zero
  
  no ip cef
  
  lane database ss 定义库FOR LECS
  
  name ww server-atm-address 47.00918100000000D058323001.00502A75AC0A.01定义VLAN和分配ATM口
  
   name ww server-atm-address 47.00918100000000D058323001.00503E1DF011.01 
  
  name ww server-atm-address 47.00918100000000D05832B001.00503E1DF011.01
  
  name ww elan-id 1 定义VLAN ID 
  
  name access server-atm-address 47.00918100000000D058323001.00502A75AC0A.02
  
  name access server-atm-address 47.00918100000000D058323001.00503E1DF011.02
  
  name access server-atm-address 47.00918100000000D05832B001.00503E1DF011.02
  
  name access elan-id 2
  
  client-atm-address 47.00918100000000D058323001.0020485A1E33.00 name ww 定义在客户端的ATM地址对应vlan名字,只有客户设备ATM非自动寻址时才设置。
  
  
  
  client-atm-address 47.00918100000000D058323001.08002097B110.00 name yy
  
  client-atm-address 47.00918100000000D058323001.08002097B111.00 name ww
  
  client-atm-address 47.00918100000000D058323001.08002097B630.00 name yy
  
  interface ATM1/0
  
  no ip address
  
  no ip directed-broadcast
  
  no ip route-cache distributed
  
  atm pvc 1 0 5 qsaal
  
  atm pvc 2 0 16 ilmi
  
  no atm ilmi-keepalive
  
  lane config auto-config-atm-address
  
  lane config database ss
  
  interface ATM1/0.1 multipoint
  
  ip address 172.16.1.249 255.255.255.0
  
  no ip redirects
  
  no ip directed-broadcast
  
  lane server-bus ethernet default
  
  lane client ethernet default
  
  no cdp enable
  
  standby 1 ip 172.16.1.250 定义连接来的VLAN网关
  
  interface ATM1/0.2 multipoint
  
  ip address 172.16.2.249 255.255.255.0
  
  no ip redirects
  
  no ip directed-broadcast
  
  lane server-bus ethernet access
  
  lane client ethernet
  
  no cdp enable
  
  standby 2 ip 172.16.2.250
  
  interface ATM1/0.3 multipoint
  
  ip address 172.17.1.249 255.255.0.0
  
  no ip redirects
  
  no ip directed-broadcast
  
  lane client ethernet ww
  
  no cdp enable
  
  standby 3 ip 172.17.1.250
  
  router eigrp 1
  
  redistribute rip metric 1000 100 10 10 1500
  
  network 10.0.0.0
  
  network 172.16.0.0
  
  network 172.17.0.0
  
  network 172.18.0.0
  
  no auto-summary
  
  router rip
  
  redistribute eigrp 1 metric 4
  
  network 172.18.0.0
  
  snmp-server community public RW
  
  snmp-server community private RO
  
  以上是较常用的路由器配法