配置实例:CISCO7400做PPPOE SERVER

1/6/2008来源:Cisco网络人气:2924


  Current configuration : 2496 bytes
  !
  version 12.2
  service timestamps debug uptime
  service timestamps log uptime
  no service passWord-encryption
  !
  hostname Router
  !
  aaa new-model
  !
  !
  aaa group server radius pppoe
  server 10.72.253.16 auth-port 1645 acct-port 1646
  server 10.72.253.50 auth-port 1645 acct-port 1646
  !
  aaa authentication ppp default group pppoe
  aaa authorization network default group pppoe
  aaa accounting network default start-stop group pppoe
  aaa session-id common
  enable secret 5 $1$GJzG$hcJHvS/UMgYIf.GP3Xc/H1
  !
  username cisco password 0 cisco
  ip subnet-zero
  !
  !
  no ip domain-lookup
  ip domain-name jxtvnet
  ip name-server 10.72.255.131
  !
  ip audit notify log
  ip audit po max-events 100
  ip ssh time-out 120
  ip ssh authentication-retries 3
  vpdn enable
  !
  vpdn-group PPPOE
  accept-dialin
  PRotocol pppoe
  virtual-template 10
  pppoe limit max-sessions 500
  !
  async-bootp dns-server 10.72.255.131 10.72.255.132
  !
  crypto mib ipsec flowmib history tunnel size 200
  crypto mib ipsec flowmib history failure size 200
  interface Loopback0
  ip address 10.1.1.1 255.255.255.0
  !
  interface GigabitEthernet0/0
  no ip address
  duplex full
  speed 100
  media-type rj45
  pppoe enable
  !
  interface GigabitEthernet0/0.1
  encapsulation dot1Q 1 native
  ip address 172.19.4.254 255.255.255.248
  !
  interface GigabitEthernet0/0.2
  encapsulation dot1Q 2
  pppoe enable
  !
  interface GigabitEthernet0/0.3
  encapsulation dot1Q 3
  pppoe enable
  !
  interface GigabitEthernet0/0.4
  encapsulation dot1Q 4
  ip address 172.19.4.193 255.255.255.224
  !
  interface GigabitEthernet0/0.507
  encapsulation dot1Q 507
  pppoe enable
  !
  interface GigabitEthernet0/0.699
  encapsulation dot1Q 699
  pppoe enable
  !
  interface GigabitEthernet0/0.701
  encapsulation dot1Q 701
  pppoe enable
  !
  interface GigabitEthernet0/1
  ip address 172.19.4.2 255.255.255.252
  duplex full
  speed 100
  media-type rj45
  !
  interface Virtual-Template10
  mtu 1492
  ip unnumbered GigabitEthernet0/1
  no peer default ip address
  ppp authentication chap
  !
  ip classless
  ip route 0.0.0.0 0.0.0.0 172.19.4.1
  no ip http server
  ip pim bidir-enable
  !
  !
  snmp-server community jxnc-tv-ro RO
  snmp-server community jxnc-tv-rw RW
  !
  !
  radius-server host 10.72.253.16 auth-port 1645 acct-port 1646 key cisco
  radius-server host 10.72.253.50 auth-port 1645 acct-port 1646 key cisco
  radius-server retransmit 3
  call rsvp-sync
  !
  !
  mgcp profile default
  !
  dial-peer cor custom
  !
  !
  !
  !
  !
  gatekeeper
  shutdown
  !
  !
  line con 0
  login authentication no_tacacs
  line aux 0
  line vty 0 4
  password cisco
  !
  !
  end
  
  说明一下:
  1、做了一个PPPOE RADIUS SERVER组,目的是提高网络的可靠性。
  相关配置:
  aaa new-model
  !
  !
  aaa group server radius pppoe
  server 10.72.253.16 auth-port 1645 acct-port 1646
  server 10.72.253.50 auth-port 1645 acct-port 1646
  !
  aaa authentication ppp default group pppoe
  aaa authorization network default group pppoe
  aaa accounting network default start-stop group pppoe
  aaa session-id common
  radius-server host 10.72.253.16 auth-port 1645 acct-port 1646 key cisco
  radius-server host 10.72.253.50 auth-port 1645 acct-port 1646 key cisco
  radius-server retransmit 3