Cisco 2501做 pppoe 虚拟拨号实例

1/6/2008来源:Cisco网络人气:2907


  需求最低的IOS是“REMOTE access SERVER”特性集
  c2500-c-l.123-5b.bin
  2500系列
  要改接口的MTU。不然会有一些问题。)
  
  下面的配置是可以用的。
  而且用 2501 就可以做了。
  我看到以前网上一些人的配置是用26做的。说25不能做。
  而且还必须是两个ethenet 口。其实不用
  一个ethernet 口一样做。
  而且用的还很好 :)
  但是用2505 是不行的。
  2505的接口是hub口。不是ethernet 口。
  我现在还没有找到一个合适的ios版本。即支持pppoe client 又支持 hub接口。
  
  REMOTE ACCESS SERVER的特征级,不支持hub接口。
  12.2 enterPRise版本不支持pppoe client。郁闷了好一段时间。
  
  这个配置同样使用与17 26等设备。
  大家可以测试一下。
  关于用ADSL做vpn。
  我记得以前贴过 :)
  用25是不行了。
  这个feature不支持 ipsec
  支持ipsec 的版本不支持 pppoe client
  需要用 26 的才可以 :)
  26有支持两个feature的ios版本。
  
  nfshanq#sh run
  Building configuration...
  
  Current configuration : 1241 bytes
  !
  version 12.3
  service timestamps debug datetime msec
  service timestamps log datetime msec
  no service passWord-encryption
  service tcp-small-servers
  !
  hostname nfshanq
  !
  boot-start-marker
  boot-end-marker
  !
  
  !
  
  ip subnet-zero
  ip name-server 202.96.134.133
  !
  !
  !
  !
  !
  interface Ethernet0
  ip address 192.168.7.2 255.255.255.0
  ip mtu 1492
  ip nat inside
  no ip route-cache
  ip tcp adjust-mss 1442
  pppoe enable
  pppoe-client dial-pool-number 1 dial-on-demand
  !
  interface Serial0
  no ip address
  no ip route-cache
  shutdown
  !
  interface Serial1
  no ip address
  no ip route-cache
  shutdown
  !
  interface Dialer1
  mtu 1492
  ip address negotiated
  ip nat outside
  encapsulation ppp
  dialer pool 1
  dialer idle-timeout 0
  dialer-group 1
  ppp authentication pap callin
  ppp pap sent-username test password 0 test
  !
  ip nat inside source list 100 interface Dialer1 overload
  no ip http server
  ip classless
  ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
  !
  
  access-list 100 permit ip 192.168.7.0 0.0.0.255 any
  dialer-list 1 protocol ip permit
  !
  line con 0
  line aux 0
  transport input all
  line vty 0 4
  !
  !
  end