CISCO GGSN 配置

1/6/2008来源:Cisco网络人气:3037


  !
  version 12.0
  no service pad
  service timestamps debug uptime
  service timestamps log uptime
  no service passWord-encryption
  service gPRs ggsn
  !
  hostname c7206-4
  !
  aaa new-model
  aaa authentication ppp default radius
  aaa authorization network default radius
  enable password mypass
  !
  ip subnet-zero
  ip domain-name gprs.com
  ip name-server 99.100.0.2
  ip dhcp excluded-address 60.0.0.1
  !
  ! local IP address pool
  ip dhcp pool 1
  network 60.0.0.0 255.255.255.0
  !
  ip address-pool dhcp-proxy-client
  ip dhcp-server 60.0.0.1
  ip dhcp-server 99.100.0.3
  !
  interface Loopback0
  ip address 60.0.0.1 255.0.0.0
  no ip directed-broadcast
  no ip route-cache
  no ip mroute-cache
  !
  interface Tunnel0
  ip address 97.0.0.1 255.0.0.0
  no ip directed-broadcast
  ip mtu 1476
  tunnel source 4.0.0.1
  tunnel destination 131.108.164.19
  !
  ! Interface to communicate with Virtual Template on SGSN
  interface FastEthernet0/0
  ip address 35.0.0.2 255.0.0.0
  ip helper-address 99.100.0.3
  no ip directed-broadcast
  no ip route-cache
  no ip mroute-cache
  no keepalive
  !
  ! interface to communicate with the PDN
  interface FastEthernet1/0
  ip address 4.0.0.1 255.0.0.0
  no ip directed-broadcast
  no ip route-cache
  no ip mroute-cache
  !
  ! Interface to TFTP server
  interface Ethernet2/0
  ip address 99.102.0.54 255.255.0.0
  no ip directed-broadcast
  no ip route-cache
  no ip mroute-cache
  !
  !
  ! Virtual Template configuration
  interface virtual-template 1
  ip address 10.10.10.1 255.255.255.0
  no ip directed-broadcast
  encapsulation gtp
  gprs access-point-list abc
  ip classless
  !
  ! Route for the virtual template on the SGSN
  ip route 1.1.1.1 255.255.255.255 FastEthernet0/0
  access-list 101 deny ip host 4.0.0.2 host 2.0.0.1
  dialer-list 1 protocol ip permit
  snmp-server community public RW
  !
  !
  ! Global DHCP server, charging server, and RADIUS server information
  gprs default dhcp-server 99.100.0.3
  gprs default charging-gateway 99.100.0.3 99.100.0.2
  gprs charging server-switch-timer 0
  !
  radius-server host 99.100.0.2 auth-port 1645 acct-port 1646
  radius-server key mykey
  !
  !
  ! access-point list configuration
  ! access point for access to PDN
  gprs access-point-list abc
  access-point 1
  access-point-name gprs.company.com
  dhcp-server 99.100.0.3
  exit
  !
  !access point for access to a private network
  access-point 2
  access-point-name xyz.com
  dhcp-server 60.0.0.1
  dhcp-gateway-address 60.0.0.1
  use-interface Tunnel0 next-hop-address 97.0.0.21
  exit
  !
  ! access point for access to PDN
  access-point 3
  access-point-name www.gprs_mycompany
  access-mode non-transparent
  radius-server 99.100.0.2
  exit
  !
  line con 0
  exec-timeout 0 0
  transport input none
  line aux 0
  exec-timeout 0 0
  transport input all
  line vty 0 4
  exec-timeout 0 0
  password mypass
  !
  end