CISCO 技术大集合(2)

1/6/2008来源:Cisco网络人气:3375


  5. Cisco765M通过ISDN拨号上263
  由于Cisco765的设置命令与我们常用的Cisco路由器的命令不同,所以以下列举了通过Cisco765上263访问Internet的具体命令行设置步骤。
  
  >set system c765
  c765> set multidestination on
  c765> set switch net3
  c765> set ppp multilink on
  c765> cd lan
  c765:LAN> set ip routing on
  c765:LAN> set ip address 10.0.0.1
  c765:LAN> set ip netmask 255.0.0.0
  c765:LAN> set briding off
  c765:LAN>cd
  c765> set user remotenet
  New user remotenet being created
  c765:remotenet> set ip routing on
  c765:remotenet> set bridging off
  c765:remotenet> set ip framing none
  c765:remotenet> set ppp clientname 263
  c765:remotenet> set ppp passWord client
  Enter new Password: 263
  Re-Type new Password: 263
  c765:remotenet> set ppp authentication out none
  c765:remotenet> set ip address 0.0.0.0
  c765:remotenet> set ip netmask 0.0.0.0
  c765:remotenet> set ppp address negotiation local on
  c765:remotenet> set ip pat on
  c765:remotenet> set ip route destination 0.0.0.0/0 gateway 0.0.0.0
  c765:remotenet> set number 2633
  c765:remotenet> set active
  命令描述如下:
  任务 命令
  设置路由器系统名称 set system c765
  答应路由器呼叫多个目的地 set multidestination on
  设置ISDN交换机类型为NET3 set switch net3
  答应点到点间多条通道连接实现负载均衡 set ppp multilink on
  关掉桥接 set briding off
  建立用户预制文件用于设置拨号连接参数- 可以设置多个用户预制文件用于相同的物理端口对应于不同的连接。 set user remotenet
  使用PPP/IPCP set ip framing none
  设置上网用户帐号 set ppp clientname 263
  设置上网口令 set ppp password client Enter new Password: 263 Re-Type new Password: 263
  不用PPP/CHAP或PAP做认证 set ppp authentication out none
  答应地址磋商 set ppp address negotiation local on
  设置地址翻译 set ip pat on
  设置默认路由 set ip route destination 0.0.0.0/0 gateway 0.0.0.0
  设置ISP的电话号码 set number 2633
  激活用户预制文件 set active
   
  返回目录
   
  六、PSTN
    电话网络(PSTN)是目前普及程度最高、成本最低的公用通讯网络,它在网络互连中也有广泛的应用。电话网络的应用一般可分为两种类型,一种是同等级别机构之间以按需拨号(DDR)的方式实现互连,一种是ISP为拨号上网为用户提供的远程访问服务的功能。
  1. 远程访问
  
  1.1.access Server基本设置:
  选用Cisco2511作为访问服务器,采用IP地址池动态分配地址.远程工作站使用WIN95拨号网络实现连接。
  全局设置:
  任务 命令
  设置用户名和密码 username username password password
  设置用户的IP地址池 ip local pool {default pool-name low-ip-address [high-ip-address]}
  指定地址池的工作方式 ip address-pool [dhcp-PRoxy-client local]
  基本接口设置命令:
  任务 命令
  设置封装形式为PPP encapsulation ppp
  启动异步口的路由功能 async default routing
  设置异步口的PPP工作方式 async mode {dedicated interactive}
  设置用户的IP地址 peer default ip address {ip-address dhcp pool [pool-name]}
  设置IP地址与Ethernet0相同 ip unnumbered ethernet0
  line拨号线设置:
  任务 命令
  设置modem的工作方式 modem {inoutdialin}
  自动配置modem类型 modem autoconfig discovery
  设置拨号线的通讯速率 speed speed
  设置通讯线路的流控方式 flowcontrol {none software [lock] [in out] hardware [in out]}
  连通后自动执行命令 autocommand command
  访问服务器设置如下:
  Router:
  hostname Router
  enable secret 5 $1$EFqU$tYLJLrynNUKzE4bx6fmH//
  !
  interface Ethernet0
  ip address 10.111.4.20 255.255.255.0
  !
  interface Async1
  ip unnumbered Ethernet0
  encapsulation ppp
  keepalive 10
  async mode interactive
  peer default ip address pool Cisco2511-Group-142
  !
  ip local pool Cisco2511-Group-142 10.111.4.21 10.111.4.36
  !
  line con 0
  exec-timeout 0 0
  password cisco
  !
  line 1 16
  modem InOut
  modem autoconfigure discovery
  flowcontrol hardware
  !
  line aux 0
  transport input all
  line vty 0 4
  password cisco
  !
  end
  相关调试命令:
  show interface
  show line
  1.2. Access Server通过Tacacs服务器实现安全认证:
  使用一台WINDOWS NT服务器作为Tacacs服务器,地址为10.111.4.2,运行Cisco2511随机带的Easy ACS 1.0软件实现用户认证功能.
  相关设置:
  任务 命令
  激活AAA访问控制 aaa new-model
  用户登录时默认起用Tacacs+做AAA认证 aaa authentication login default tacacs+
  列表名为no_tacacs使用ENABLE口令做认证 aaa authentication login no_tacacs enable
  在运行PPP的串行线上采用Tacacs+做认证 aaa authentication ppp default tacacs+
  由TACACS+服务器授权运行EXEC aaa authorization exec tacacs+
  由TACACS+服务器授权与网络相关的服务请求。 aaa authorization network tacacs+
  为EXEC会话运行记帐.进程开始和结束时发通告给TACACS+服务器。 aaa accounting exec start-stop tacacs+
  为与网络相关的服务需求运行记帐包括SLIP,PPP,PPP NCPs,ARAP等.在进程开始和结束时发通告给TACACS+服务器。 aaa accounting network start-stop tacacs+
  指定Tacacs服务器地址 tacacs-server host 10.111.4.2
  在Tacacs+服务器和访问服务器设定共享的要害字,访问服务器和Tacacs+服务器使用这个要害字去加密口令和响应信息。这里使用tac作为要害字。 tacacs-server key tac
  访问服务器设置如下:
  hostname router
  !
  aaa new-model
  aaa authentication login default tacacs+
  aaa authentication login no_tacacs enable
  aaa authentication ppp default tacacs+
  aaa authorization exec tacacs+
  aaa authorization network tacacs+
  aaa accounting exec start-stop tacacs+
  aaa accounting network start-stop tacacs+
  enable secret 5 $1$kN4g$CvS4d2.rJzWntCnn/0hvE0
  !
  interface Ethernet0
  ip address 10.111.4.20 255.255.255.0
  !
  interface Serial0
  no ip address
  shutdown
  interface Serial1
  no ip address
  shutdown
  !
  interface Group-Async1
  ip unnumbered Ethernet0
  encapsulation ppp
  async mode interactive
  peer default ip address pool Cisco2511-Group-142
  no cdp enable
  group-range 1 16
  !
  ip local pool Cisco2511-Group-142 10.111.4.21 10.111.4.36
  tacacs-server host 10.111.4.2
  tacacs-server key tac
  !
  line con 0
  exec-timeout 0 0
  password cisco
  login authentication no_tacacs
  line 1 16
  login authentication tacacs
  modem InOut
  modem autoconfigure type usr_courier
  autocommand ppp
  transport input all
  stopbits 1
  rxspeed 115200
  txspeed 115200
  flowcontrol hardware
  line aux 0
  transport input all
  line vty 0 4
  password cisco
  !
  end
  2. DDR(dial-on-demand routing)实例
  此例通过Cisco 2500系列路由器的aux端口实现异步拨号DDR连接。Router1拨号连接到Router2。其中采用PPP/CHAP做安全认证,在Router1中应建立一个用户,以对端路由器主机名作为用户名,即用户名应为Router2。同时在Router2中应建立一个用户,以对端路由器主机名作为用户名,即用户名应为Router1。所建的这两用户的password必须相同。
  相关命令如下:
  任务 命令
  设置路由器与modem的接口指令 chat-script script-name EXPECT SEND EXPECT SEND (etc.)
  设置端口在挂断前的等待时间 dialer idle-timeout seconds
  设置协议地址与电话号码的映射 dialer map protocol next-hop-address [name hostname] [broadcast] [modem-script modem-regexp] [system-script system-regexp] [dial-string]
  设置电话号码 dialer string dial-string
  指定在特定线路下路由器默认 使用的chat-script script {dialerreset} script-name
  Router1:
  hostname Router1
  !
  enable secret 5 $1$QKI7$wXjpFqC74vDAyKBUMallw/
  !
  username Router2 password cisco
  chat-script cisco-default "" "AT" TIMEOUT 30 OK "ATDT \T" TIMEOUT 30 CONNECT \c
  !
  interface Ethernet0
  ip address 10.0.0.1 255.255.255.0
  !
  interface Async1
  ip address 192.200.10.1 255.255.255.0
  encapsulation ppp
  async default routing
  async mode dedicated
  dialer in-band
  dialer idle-timeout 60
  dialer map ip 192.200.10.2 name Router2 modem-script cisco-default 573
  dialer-group 1
  ppp authentication chap
  !
  ip route 10.0.1.0 255.255.255.0 192.200.10.2
  dialer-list 1 protocol ip permit
  !
  line con 0
  line aux 0
  modem InOut
  modem autoconfigure discovery
  flowcontrol hardware
  
  Router2:
  hostname Router2
  !
  enable secret 5 $1$F6EV$5U8puzNt2/o9g.t56PXHo.
  !
  username Router1 password cisco
  !
  interface Ethernet0
  ip address 10.0.1.1 255.255.255.0
  !
  interface Async1
  ip address 192.200.10.2 255.255.255.0
  encapsulation ppp
  async default routing
  async mode dedicated
  dialer in-band
  dialer idle-timeout 60
  dialer map ip 192.200.10.1 name Router1
  dialer-group 1
  ppp authentication chap
  !
  ip route 10.0.0.0 255.255.255.0 192.200.10.1
  dialer-list 1 protocol ip permit
  !
  line con 0
  line aux 0
  modem InOut
  modem autoconfigure discovery
  flowcontrol hardware
  !
  相关调试命令:
  debug dialer
  debug ppp authentication
  debug ppp error
  debug ppp negotiation
  debug ppp packet
  show dialer
  3. 异步拨号备份DDN专线:
  此例主连接采用DDN专线,备份线路为电话拨号。当DDN专线连接正常时,主端口S0状态为up,line protocol亦为up,则备份线路状态为standby,line protocol为down,此时所有通信均通过主接口进行。当主接口连接发生故障时,端口状态为down,则激活备份接口,完成数据通信。此方法不适合为X.25做备份。因为,配置封装为X.25的接口只要和X.25交换机之间的连接正常其接口及line protocol的状态亦为 up,它并不考虑其它地方需与之通信的路由器的状态如何,所以若本地路由器状态正常,而对方路由器连接即使发生故障,本地也不会激活备份线路。例4将会描述如何为X.25做拨号备份。
  以下是相关命令:
  任务 命令
  指定主线路改变后,次线路状态发生改变的延迟时间 backup delay {enable-delay never} {disable-delay never}
  指定一个接口作为备份接口 backup interface type number
  hostname c2522rb
  !
  enable secret 5 $1$J5vn$ceYDe2FwPhrZi6qsIIz6g0
  enable password cisco
  !
  username c4700 password 0 cisco
  ip subnet-zero
  chat-script cisco-default "" "AT" TIMEOUT 30 OK "ATDT \T" TIMEOUT 30 CONNECT \c
  chat-script reset atz
  !
  interface Ethernet0
  ip address 16.122.51.254 255.255.255.0
  no ip mroute-cache
  !
  interface Serial0
  backup delay 10 10
  backup interface Serial2
  ip address 16.250.123.18 255.255.255.252
  no ip mroute-cache
  no fair-queue
  !
  interface Serial1
  no ip address
  no ip mroute-cache
  shutdown
  !
  interface Serial2
  physical-layer async
  ip address 16.249.123.18 255.255.255.252
  encapsulation ppp
  async mode dedicated
  dialer in-band
  dialer idle-timeout 60
  dialer map ip 16.249.123.17 name c4700 6825179
  dialer-group 1
  ppp authentication chap
  !
  interface Serial3
  no ip address
  shutdown
  no cdp enable
  !
  interface Serial4
  no ip address
  shutdown
  no cdp enable
  !
  interface Serial5
  no ip address
  no ip mroute-cache
  shutdown
  !
  interface Serial6
  no ip address
  no ip mroute-cache
  shutdown
  !
  interface Serial7
  no ip address
  no ip mroute-cache
  shutdown
  !
  interface Serial8
  no ip address
  no ip mroute-cache
  shutdown
  !
  interface Serial9
  no ip address
  no ip mroute-cache
  shutdown
  !
  interface BRI0
  no ip address
  no ip mroute-cache
  shutdown
  !
  router eigrp 200
  network 16.0.0.0
  !
  ip classless
  !
  dialer-list 1 protocol ip permit
  !
  line con 0
  line 2
  script dialer cisco-default
  script reset reset
  modem InOut
  modem autoconfigure discovery
  rxspeed 38400
  txspeed 38400
  flowcontrol hardware
  line aux 0
  line vty 0 4
  password cisco
  login
  !
  end
  c2522rb#
  4. 异步拨号备份X.25:
  设置X.25的拨号备份,首先X.25连接的端口必须运行动态路由协议,异步拨号口必须使用静态路由.本例选择EIGRP作为路由选择协议,将静态路由的Metric的值设置为200,由于EIGRP的默认Metric为90,所以当同时有两条路径通往同一网段时,其中Metric值小的路径生效,而当X.25连接出现问题时,路由器无法通过路由协议学习到路由表,则此时静态路由生效,访问通过拨号端口实现。当X.25连接恢复正常时,路由器又可以学习到路由表,则由于 Metric值的不同,静态路由自动被动态路由所代替,这样就实现了备份的功能。
  路由器Router1配置如下:
  hostname router1
  !
  enable secret 5 $1$UTvD$99YiY2XsRMxHudcYeHn.Y.
  enable password cisco
  !
  username router2 password cisco
  ip subnet-zero
  chat-script cisco-default "" "AT" TIMEOUT 30 OK "ATDT \T" TIMEOUT 30 CONNECT \c
  chat-script reset atz
  interface Ethernet0
  ip address 202.96.38.100 255.255.255.0
  !
  interface Serial0
  ip address 202.96.0.1 255.255.255.0
  encapsulation x25
  x25 address 10112227
  x25 htc 16
  x25 map ip 202.96.0.2 10112225 broadcast
  !
  interface Serial1
  no ip address
  shutdown
  !
  !
  interface Async 1
  ip address 202.96.1.1 255.255.255.252
  encapsulation ppp
  dialer in-band
  dialer idle-timeout 60
  dialer map ip 202.96.1.2 name router2 modem-script cisco-default 2113470
  dialer-group 1
  ppp authentication chap
  !
  router eigrp 200
  redistribute connected
  network 202.96.0.0
  !
  ip route 202.96.37.0 255.255.255.0 202.96.1.2 200
  dialer-list 1 protocol ip permit
  line con 0
  line aux 0
  script dialer cisco-default
  script reset reset
  modem InOut
  modem autoconfigure discovery
  transport input all
  rxspeed 38400
  txspeed 38400
  flowcontrol hardware
  line vty 0 4
  password cisco
  login
  !
  end
  路由器Router2配置如下:
  hostname router2
  !
  enable secret 5 $1$T4IU$2cIqak8f/E4Ug6dLT0k.J0
  enable password cisco
  !
  username router1 password cisco
  ip subnet-zero
  chat-script cisco-default "" "AT" TIMEOUT 30 OK "ATDT \T" TIMEOUT 30 CONNECT \c
  chat-script reset atz
  !
  interface Ethernet0
  ip address 202.96.37.100 255.255.255.0
  !
  interface Serial0
  ip address 202.96.0.2 255.255.255.0
  no ip mroute-cache
  encapsulation x25
  x25 address 10112225
  x25 htc 16
  x25 map ip 202.96.0.1 10112227 broadcast
  !
  interface Serial1
  no ip address
  shutdown
  !
  interface Async1
  ip address 202.96.1.2 255.255.255.252
  encapsulation ppp
  keepalive 30
  async default routing
  async mode dedicated
  dialer in-band
  dialer idle-timeout 60
  dialer wait-for-carrier-time 120
  dialer map ip 202.96.1.1 name router1 modem-script cisco-default 2113469
  dialer-group 1
  ppp authentication chap
  !
  router eigrp 200
  redistribute static
  network 202.96.0.0
  !
  no ip classless
  ip route 202.96.38.0 255.255.255.0 202.96.1.1 200
  dialer-list 1 protocol ip permit
  !
  line con 0
  exec-timeout 0 0
  line aux 0
  script reset reset
  modem InOut
  modem autoconfigure discovery
  transport input all
  rxspeed 38400
  txspeed 38400
  flowcontrol hardware
  line vty 0 4
  password cisco
  login
  !
  end
   
  路由协议:
  
  一、RIP协议
   
  RIP(Routing information Protocol)是应用较早、使用较普遍的内部网关协议(Interior Gateway Protocol,简称IGP),适用于小型同类网络,是典型的距离向量(distance-vector)协议。文档见RFC1058、RFC1723。
  RIP通过广播UDP报文来交换路由信息,每30秒发送一次路由信息更新。RIP提供跳跃计数(hop count)作为尺度来衡量路由距离,跳跃计数是一个包到达目标所必须经过的路由器的数目。假如到相同目标有二个不等速或不同带宽的路由器,但跳跃计数相同,则RIP认为两个路由是等距离的。RIP最多支持的跳数为15,即在源和目的网间所要经过的最多路由器的数目为15,跳数16表示不可达。
  1. 有关命令
  任务 命令
  指定使用RIP协议 router rip
  指定RIP版本 version {12}1
  指定与该路由器相连的网络 network network
  注:1.Cisco的RIP版本2支持验证、密钥治理、路由汇总、无类域间路由(CIDR)和变长子网掩码(VLSMs)
  2. 举例
  Router1:
  router rip
  version 2
  network 192.200.10.0
  network 192.20.10.0
  !
  相关调试命令:
  show ip protocol
  show ip route
   
  返回目录
   
  
  二、IGRP协议
   
  IGRP (Interior Gateway Routing Protocol)是一种动态距离向量路由协议,它由Cisco公司八十年代中期设计。使用组合用户配置尺度,包括延迟、带宽、可靠性和负载。
  缺省情况下,IGRP每90秒发送一次路由更新广播,在3个更新周期内(即270秒),没有从路由中的第一个路由器接收到更新,则公布路由不可访问。在7个更新周期即630秒后,Cisco IOS 软件从路由表中清除路由。
  1. 有关命令
  任务 命令
  指定使用RIP协议 router igrp autonomous-system1
  指定与该路由器相连的网络 network network
  指定与该路由器相邻的节点地址 neighbor ip-address
  注:1、autonomous-system可以随意建立,并非实际意义上的autonomous-system,但运行IGRP的路由器要想交换路由更新信息其autonomous-system需相同。
  2.举例
  Router1:
  router igrp 200
  network 192.200.10.0
  network 192.20.10.0
  !
  
  三、OSPF协议
   
  OSPF(Open Shortest Path First)是一个内部网关协议(Interior Gateway Protocol,简称IGP),用于在单一自治系统(autonomous system,AS)内决策路由。与RIP相对,OSPF是链路状态路有协议,而RIP是距离向量路由协议。
  链路是路由器接口的另一种说法,因此OSPF也称为接口状态路由协议。OSPF通过路由器之间通告网络接口的状态来建立链路状态数据库,生成最短路径树,每个OSPF路由器使用这些最短路径构造路由表。
  文档见RFC2178。
  1.有关命令
  全局设置
  任务 命令
  指定使用OSPF协议 router ospf process-id1
  指定与该路由器相连的网络 network address wildcard-mask area area-id2
  指定与该路由器相邻的节点地址 neighbor ip-address
  注:1、OSPF路由进程process-id必须指定范围在1-65535,多个OSPF进程可以在同一个路由器上配置,但最好不这样做。多个OSPF进程需要多个OSPF数据库的副本,必须运行多个最短路径算法的副本。process-id只在路由器内部起作用,不同路由器的process-id可以不同。
  2、wildcard-mask 是子网掩码的反码, 网络区域ID area-id在0-4294967295内的十进制数,也可以是带有IP地址格式的x.x.x.x。当网络区域ID为0或0.0.0.0时为主干域。不同网络区域的路由器通过主干域学习路由信息。
  2.基本配置举例:
  Router1:
  interface ethernet 0
  ip address 192.1.0.129 255.255.255.192
  !
  interface serial 0
  ip address 192.200.10.5 255.255.255.252
  !
  router ospf 100
  network 192.200.10.4 0.0.0.3 area 0
  network 192.1.0.128 0.0.0.63 area 1
  !
  Router2:
  interface ethernet 0
  ip address 192.1.0.65 255.255.255.192
  !
  interface serial 0
  ip address 192.200.10.6 255.255.255.252
  !
  router ospf 200
  network 192.200.10.4 0.0.0.3 area 0
  network 192.1.0.64 0.0.0.63 area 2
  !
  Router3:
  interface ethernet 0
  ip address 192.1.0.130 255.255.255.192
  !
  router ospf 300
  network 192.1.0.128 0.0.0.63 area 1
  !
  Router4:
  interface ethernet 0
  ip address 192.1.0.66 255.255.255.192
  !
  router ospf 400
  network 192.1.0.64 0.0.0.63 area 1
  !
  相关调试命令:
  debug ip ospf events
  debug ip ospf packet
  show ip ospf
  show ip ospf database
  show ip ospf interface
  show ip ospf neighbor
  show ip route
  3. 使用身份验证
  为了安全的原因,我们可以在相同OSPF区域的路由器上启用身份验证的功能,只有经过身份验证的同一区域的路由器才能互相通告路由信息。
  在默认情况下OSPF不使用区域验证。通过两种方法可启用身份验证功能,纯文本身份验证和消息摘要(md5)身份验证。纯文本身份验证传送的身份验证口令为纯文本,它会被网络探测器确定,所以不安全,不建议使用。而消息摘要(md5)身份验证在传输身份验证口令前,要对口令进行加密,所以一般建议使用此种方法进行身份验证。
  使用身份验证时,区域内所有的路由器接口必须使用相同的身份验证方法。为起用身份验证,必须在路由器接口配置模式下,为区域的每个路由器接口配置口令。
  任务 命令
  指定身份验证 area area-id authentication [message-digest]
  使用纯文本身份验证 ip ospf authentication-key password
  使用消息摘要(md5)身份验证 ip ospf message-digest-key keyid md5 key
  以下列举两种验证设置的示例,示例的网络分布及地址分配环境与以上基本配置举例相同,只是在Router1和Router2的区域0上使用了身份验证的功能。:
  例1.使用纯文本身份验证
  Router1:
  interface ethernet 0
  ip address 192.1.0.129 255.255.255.192
  !
  interface serial 0
  ip address 192.200.10.5 255.255.255.252
  ip ospf authentication-key cisco
  !
  router ospf 100
  network 192.200.10.4 0.0.0.3 area 0
  network 192.1.0.128 0.0.0.63 area 1
  area 0 authentication
  !
  Router2:
  interface ethernet 0
  ip address 192.1.0.65 255.255.255.192
  !
  interface serial 0
  ip address 192.200.10.6 255.255.255.252
  ip ospf authentication-key cisco
  !
  router ospf 200
  network 192.200.10.4 0.0.0.3 area 0
  network 192.1.0.64 0.0.0.63 area 2
  area 0 authentication
  !
  例2.消息摘要(md5)身份验证:
  Router1:
  interface ethernet 0
  ip address 192.1.0.129 255.255.255.192
  !
  interface serial 0
  ip address 192.200.10.5 255.255.255.252
  ip ospf message-digest-key 1 md5 cisco
  !
  router ospf 100
  network 192.200.10.4 0.0.0.3 area 0
  network 192.1.0.128 0.0.0.63 area 1
  area 0 authentication message-digest
  !
  Router2:
  interface ethernet 0
  ip address 192.1.0.65 255.255.255.192
  !
  interface serial 0
  ip address 192.200.10.6 255.255.255.252
  ip ospf message-digest-key 1 md5 cisco
  !
  router ospf 200
  network 192.200.10.4 0.0.0.3 area 0
  network 192.1.0.64 0.0.0.63 area 2
  area 0 authentication message-digest
  !
  相关调试命令:
  debug ip ospf adj
  debug ip ospf events
   
  返回目录
   
  四、重新分配路由
   
  在实际工作中,我们会碰到使用多个IP路由协议的网络。为了使整个网络正常地工作,必须在多个路由协议之间进行成功的路由再分配。
  以下列举了OSPF与RIP之间重新分配路由的设置范例:
  
  Router1的Serial 0端口和Router2的Serial 0端口运行OSPF,在Router1的Ethernet 0端口运行RIP 2,Router3运行RIP2,Router2有指向Router4的192.168.2.0/24网的静态路由,Router4使用默认静态路由。需要在Router1和Router3之间重新分配OSPF和RIP路由,在Router2上重新分配静态路由和直连的路由。
  范例所涉及的命令
  任务 命令
  重新分配直连的路由 redistribute connected
  重新分配静态路由 redistribute static
  重新分配ospf路由 redistribute ospf process-id metric metric-value
  重新分配rip路由 redistribute rip metric metric-value
  Router1:
  interface ethernet 0
  ip address 192.168.1.1 255.255.255.0
  !
  interface serial 0
  ip address 192.200.10.5 255.255.255.252
  !
  router ospf 100
  redistribute rip metric 10
  network 192.200.10.4 0.0.0.3 area 0
  !
  router rip
  version 2
  redistribute ospf 100 metric 1
  network 192.168.1.0
  !
  Router2:
  interface loopback 1
  ip address 192.168.3.2 255.255.255.0
  !
  interface ethernet 0
  ip address 192.168.0.2 255.255.255.0
  !
  interface serial 0
  ip address 192.200.10.6 255.255.255.252
  !
  router ospf 200
  redistribute connected subnet
  redistribute static subnet
  network 192.200.10.4 0.0.0.3 area 0
  !
  ip route 192.168.2.0 255.255.255.0 192.168.0.1
  !
  Router3:
  interface ethernet 0
  ip address 192.168.1.2 255.255.255.0
  !
  router rip
  version 2
  network 192.168.1.0
  !
  Router4:
  interface ethernet 0
  ip address 192.168.0.1 255.255.255.0
  !
  interface ethernet 1
  ip address 192.168.2.1 255.255.255.0
  !
  ip route 0.0.0.0 0.0.0.0 192.168.0.2
  !
   
  
  五、IPX协议设置
   
  IPX协议与IP协议是两种不同的网络层协议,它们的路由协议也不一样,IPX的路由协议不象IP的路由协议那样丰富,所以设置起来比较简单。但IPX协议在以太网上运行时必须指定封装形式。
  1. 有关命令
  启动IPX路由 ipx routing
  设置IPX网络及以太网封装形式 ipx network network [encapsulation encapsulation-type]1
  指定路由协议,默认为RIP ipx router {eigrp autonomous-system-number nlsp [tag] rip}
  注:1.network 范围是1 到FFFFFFFD.
  IPX封装类型列表
  接口类型 封装类型 IPX帧类型
  Ethernet novell-ether (默认) arpa sap snap Ethernet_802.3 Ethernet_II Ethernet_802.2 Ethernet_Snap
  Token Ring sap (默认) snap Token-Ring Token-Ring_Snap
  FDDI snap (默认) sap novell-fddi Fddi_Snap Fddi_802.2 Fddi_Raw
  举例:
  在此例中,WAN的IPX网络为3a00,Router1所连接的局域网IPX网络号为2a00,在此局域网有一台Novell服务器,IPX网络号也是2a00, 路由器接口的IPX网络号必须与在同一网络的Novell服务器上设置的IPX网络号相同。路由器通过监听SAP来建立已知的服务及自己的网络地址表,并每60秒发送一次自己的SAP表。
  Router1:
  ipx routing
  interface ethernet 0
  ipx network 2a00 encapsulation sap
  !
  interface serial 0
  ipx network 3a00
  !
  ipx router eigrp 10
  network 3a00
  network 2a00
  !
  
  Router2:
  ipx routing
  interface ethernet 0
  ipx network 2b00 encapsulation sap
  !
  interface serial 0
  ipx network 3a00
  !
  ipx router eigrp 10
  network 2b00
  network 3a00
  !
  相关调试命令:
  debug ipx packet
  debug ipx routing
  debug ipx sap
  debug ipx spoof
  debug ipx spx
  show ipx eigrp interfaces
  show ipx eigrp neighbors
  show ipx eigrp topology
  show ipx interface
  show ipx route
  show ipx servers
  show ipx spx-spoof
   
  五、IPX协议设置
   
  IPX协议与IP协议是两种不同的网络层协议,它们的路由协议也不一样,IPX的路由协议不象IP的路由协议那样丰富,所以设置起来比较简单。但IPX协议在以太网上运行时必须指定封装形式。
  1. 有关命令
  启动IPX路由 ipx routing
  设置IPX网络及以太网封装形式 ipx network network [encapsulation encapsulation-type]1
  指定路由协议,默认为RIP ipx router {eigrp autonomous-system-number nlsp [tag] rip}
  注:1.network 范围是1 到FFFFFFFD.
  IPX封装类型列表
  接口类型 封装类型 IPX帧类型
  Ethernet novell-ether (默认) arpa sap snap Ethernet_802.3 Ethernet_II Ethernet_802.2 Ethernet_Snap
  Token Ring sap (默认) snap Token-Ring Token-Ring_Snap
  FDDI snap (默认) sap novell-fddi Fddi_Snap Fddi_802.2 Fddi_Raw
  举例:
  在此例中,WAN的IPX网络为3a00,Router1所连接的局域网IPX网络号为2a00,在此局域网有一台Novell服务器,IPX网络号也是2a00, 路由器接口的IPX网络号必须与在同一网络的Novell服务器上设置的IPX网络号相同。路由器通过监听SAP来建立已知的服务及自己的网络地址表,并每60秒发送一次自己的SAP表。
  Router1:
  ipx routing
  interface ethernet 0
  ipx network 2a00 encapsulation sap
  !
  interface serial 0
  ipx network 3a00
  !
  ipx router eigrp 10
  network 3a00
  network 2a00
  !
  
  Router2:
  ipx routing
  interface ethernet 0
  ipx network 2b00 encapsulation sap
  !
  interface serial 0
  ipx network 3a00
  !
  ipx router eigrp 10
  network 2b00
  network 3a00
  !
  相关调试命令:
  debug ipx packet
  debug ipx routing
  debug ipx sap
  debug ipx spoof
  debug ipx spx
  show ipx eigrp interfaces
  show ipx eigrp neighbors
  show ipx eigrp topology
  show ipx interface
  show ipx route
  show ipx servers
  show ipx spx-spoof
   
  
  4、、、章 服务质量及访问控制
  
  一、协议优先级设置
   
  1.有关命令
  任务 命令
  设置优先级表项目 priority-list list-number protocol protocol {high medium normal low} queue-keyword keyword-value
  使用指定的优先级表 priority-group list-number
  
  2.举例
  Router1:
  priority-list 1 protocol ip high tcp telnet
  priority-list 1 protocol ip low tcp FTP
  priority-list 1 default normal
  interface serial 0
  
  priority-group 1
   
  返回目录
   
  二、队列定制
   
  1.有关命令
  任务 命令
  设置队列表中包含协议 queue-list list-number protocol protocol-name queue-number queue-keyword keyword-value
  设置队列表中队列的大小 queue-list list-number queue queue-number byte-count byte-count-number
  使用指定的队列表 custom-queue-list list
  
  2.举例
  Router1:
  queue-list 1 protocol ip 0 tcp telnet
  queue-list 1 protocol ip 1 tcp www
  queue-list 1 protocol ip 2 tcp ftp
  queue-list 1 queue 0 byte-count 300
  queue-list 1 queue 1 byte-count 200
  queue-list 1 queue 2 byte-count 100
  interface serial 0
  
  custom-queue-list 1
  返回目录
   三、访问控制
   
  1.有关命令
  任务 命令
  设置访问表项目 access-list list {permit deny} address mask
  设置队列表中队列的大小 queue-list list-number queue queue-number byte-count byte-count-number
  使用指定的访问表 ip access-group list {in out}
  2.举例
  Router1:
  access-list 1 deny 192.1.3.0 0.0.0.255
  access-list 1 permit any
  interface serial 0
  
  ip access-group 1 in
   
  返回目录
   
  虚拟局域网(VLAN)路由
  
  一、虚拟局域网(VLAN)
  当前在我们构造企业网络时所采用的主干网络技术一般都是基于交换和虚拟网络的。交换技术将共享介质改为独占介质,大大提高网络速度。虚拟网络技术打破了地理环境的制约,在不改动网络物理连接的情况下可以任意将工作站在工作组或子网之间移动,工作站组成逻辑工作组或虚拟子网,提高信息系统的运作性能,均衡网络数据流量,合理利用硬件及信息资源。同时,利用虚拟网络技术,大大减轻了网络治理和维护工作的负担,降低网络维护费用。随着虚拟网络技术的应用,随之必然产生了在虚拟网间如何通讯的问题.
   
   
  返回目录
   
  二、交换机间链路(ISL)协议
    ISL(Interior Switching Link)协议用于实现交换机间的VLAN中继。它是一个信息包标记协议,在支持ISL接口上发送的帧由一个标准以太网帧及相关的VLAN信息组成。如下图所示,在支持ISL的接口上可以传送来自不同VLAN的数据。
  
   
  
  三、虚拟局域网(VLAN)路由实例
   
  3.1. 例一:
   
  
  设备选用Catalyst5500交换机1台,安装WS-X5530-E3治理引擎,多块WS-X5225R及WS-X5302路由交换模块,WS-X5302被直接插入交换机,通过二个通道与系统背板上的VLAN 相连,从用户角度看认为它是1个1接口的模块,此接口支持ISL。在交换机内划有3个虚拟网,分别名为default、qbw、rgw,通过WS-X5302实现虚拟网间路由。
  以下加重下横线部分,如set system name 5500C为需设置的命令。
  设置如下:
  Catalyst 5500配置:
  begin
  set password $1$FMFQ$HfZR5DUszVHIRhrz4h6V70
  set enablepass $1$FMFQ$HfZR5DUszVHIRhrz4h6V70
  set prompt Console>
  set length 24 default
  set logout 20
  set banner motd ^C^C
  !
  #system
  set system baud 9600
  set system modem disable
  set system name 5500C
  set system location
  set system contact
  !
  #ip
  set interface sc0 1 10.230.4.240 255.255.255.0 10.230.4.255
  set interface sc0 up
  set interface sl0 0.0.0.0 0.0.0.0
  set interface sl0 up
  set arp agingtime 1200
  set ip redirect enable
  set ip unreachable enable
  set ip fragmentation enable
  set ip route 0.0.0.0 10.230.4.15 1
  set ip alias default 0.0.0.0
  !
  #Command alias
  !
  #vtp
  set vtp domain hne
  set vtp mode server
  set vtp v2 disable
  set vtp pruning disable
  set vtp pruneeligible 2-1000
  clear vtp pruneeligible 1001-1005
  set vlan 1 name default type ethernet mtu 1500 said 100001 state active
  set vlan 777 name rgw type ethernet mtu 1500 said 100777 state active
  set vlan 888 name qbw type ethernet mtu 1500 said 100888 state active
  set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
  set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active bridge 0x0 stp ieee
  set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active bridge 0x0 stp ibm
  set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state active parent 0 ring 0x0 mode srb aremaxhop 7 stemaxhop 7
  !
  #set boot command
  set boot config-register 0x102
  set boot system Flash bootflash:cat5000-sup3.4-3-1a.bin
  !
  #module 1 : 2-port 1000BaseLX Supervisor
  set module name 1
  set vlan 1 1/1-2
  set port enable 1/1-2
  !
  #module 2 : empty
  !
  #module 3 : 24-port 10/100BaseTX Ethernet
  set module name 3
  set module enable 3
  set vlan 1 3/1-22
  set vlan 777 3/23
  set vlan 888 3/24
  set trunk 3/1 on isl 1-1005
  #module 4 empty
  !
  #module 5 empty
  !
  #module 6 : 1-port Route Switch
  set module name 6
  set port level 6/1 normal
  set port trap 6/1 disable
  set port name 6/1
  set cdp enable 6/1
  set cdp interval 6/1 60
  set trunk 6/1 on isl 1-1005
  !
  #module 7 : 24-port 10/100BaseTX Ethernet
  set module name 7
  set module enable 7
  set vlan 1 7/1-22
  set vlan 888 7/23-24
  set trunk 7/1 on isl 1-1005
  set trunk 7/2 on isl 1-1005
  !
  #module 8 empty
  !
  #module 9 empty
  !
  #module 10 : 12-port 100BaseFX MM Ethernet
  set module name 10
  set module enable 10
  set vlan 1 10/1-12
  set port channel 10/1-4 off
  set port channel 10/5-8 off
  set port channel 10/9-12 off
  set port channel 10/1-2 on
  set port channel 10/3-4 on
  set port channel 10/5-6 on
  set port channel 10/7-8 on
  set port channel 10/9-10 on
  set port channel 10/11-12 on
  #module 11 empty
  !
  #module 12 empty
  !
  #module 13 empty
  !
  #switch port analyzer
  !set span 1 1/1 both inpkts disable
  set span disable
  !
  #cam
  set cam agingtime 1-2,777,888,1003,1005 300
  end
  5500C> (enable)
  WS-X5302路由模块设置:
  Router#wri t
  Building configuration...
  Current configuration:
  !
  version 11.2
  no service password-encryption
  no service udp-small-servers
  no service tcp-small-servers
  !
  hostname Router
  !
  enable secret 5 $1$w1kK$AJK69fGOD7BqKhKcSNBf6.
  !
  ip subnet-zero
  !
  interface Vlan1
  ip address 10.230.2.56 255.255.255.0
  !
  interface Vlan777
  ip address 10.230.3.56 255.255.255.0
  !
  interface Vlan888
  ip address 10.230.4.56 255.255.255.0
  !
  no ip classless
  !
  line con 0
  line aux 0
  line vty 0 4
  password router
  login
  !
  end
  Router#
  3.1. 例二:
  交换设备仍选用Catalyst5500交换机1台,安装WS-X5530-E3治理引擎,多块WS-X5225R在交换机内划有3个虚拟网,分别名为default、qbw、rgw,通过Cisco3640路由器实现虚拟网间路由。交换机设置与例一类似。
  路由器Cisco3640,配有一块NM-1FE-TX模块,此模块带有一个快速以太网接口可以支持ISL。Cisco3640快速以太网接口与交换机上的某一支持ISL的端口实现连接,如交换机第3槽第1个接口(3/1口)。
  Router#wri t
  Building configuration...
  Current configuration:
  !
  version 11.2
  no service password-encryption
  no service udp-small-servers
  no service tcp-small-servers
  !
  hostname Router
  !
  enable secret 5 $1$w1kK$AJK69fGOD7BqKhKcSNBf6.
  !
  ip subnet-zero
  !
  interface FastEthernet1/0
  !
  interface FastEthernet1/0.1
  encapsulation isl 1
  ip address 10.230.2.56 255.255.255.0
  !
  interface FastEthernet1/0.2
  encapsulation isl 777
  ip address 10.230.3.56 255.255.255.0
  !
  interface FastEthernet1/0.3
  encapsulation isl 888
  ip address 10.230.4.56 255.255.255.0
  !
  no ip classless
  !
  line con 0
  line aux 0
  line vty 0 4
  password router
  login
  !
  end
  Router#
   
  返回目录
  
  参考参考:
   
  1、Cisco路由器口令恢复
  当Cisco路由器的口令被错误修改或忘记时,可以按如下步骤进行操作:
  1. 开机时按使进入ROM监控状态
  2. 按o 命令读取配置寄存器的原始值
  > o 一般值为0x2102
  3. 作如下设置,使忽略NVRAM引导
  >o/r0x**4* Cisco2500系列命令
  rommon 1 >confreg 0x**4* Cisco2600、1600系列命令
  一般正常值为0x2102
  4. 重新启动路由器
  >I
  rommon 2 >reset
  5. 在“Setup”模式,对所有问题回答No
  6. 进入特权模式
  Router>enable
  7. 下载NVRAM
  Router>configure memory
  8. 恢复原始配置寄存器值并激活所有端口
  “hostname”#configure terminal
  “hostname”(config)#config-register 0x“value”
  “hostname”(config)#interface xx
  “hostname”(config)#no shutdown
  9. 查询并记录丢失的口令
  “hostname”#show configuration (show startup-config)
  10. 修改口令
  “hostname”#configure te