CISCO 4908的配置实例

1/6/2008来源:Cisco网络人气:3503

CISCO 4908G配置:
  sh run
  Building configuration...
  
  Current configuration:
  !
  version 12.0
  no service pad
  service timestamps debug uptime
  service timestamps log uptime
  no service passWord-encryption
  !
  hostname Router
  !
  enable password cisco 进去特权模式的密码
  !
  username cisco password 0 cisco 远程telnet治理登陆的用户名和密码
  ip subnet-zero
  bridge irb 桥接路由
  !
  !
  !
  interface Port-channel1 建立一个快速通道
   no ip address
   no ip directed-broadcast
   hold-queue 300 in
  !
  interface Port-channel1.1 设置快速通道的vlan1接口,子端口1
   encapsulation dot1Q 1 native 封装802.1q协议,设置为vlan 1
   no ip redirects
   no ip directed-broadcast
   bridge-group 1 桥接本交换机所有的vlan 1
  !
  interface Port-channel1.2 设置快速通道vlan 2接口,子端口2
   encapsulation dot1Q 2 封装802.1q协议,设置为vlan 2
   no ip redirects
   no ip directed-broadcast
   bridge-group 2 桥接本交换机的 vlan 2
  !
  interface Port-channel1.3
   encapsulation dot1Q 3
   no ip redirects
   no ip directed-broadcast
   bridge-group 3
  !
  interface Port-channel1.4
   encapsulation dot1Q 4
   no ip redirects
   no ip directed-broadcast
   bridge-group 4
  !
  interface Port-channel1.5
   encapsulation dot1Q 5
   no ip redirects
   no ip directed-broadcast
   bridge-group 5
  !
  interface Port-channel1.6
   encapsulation dot1Q 6
   no ip redirects
   no ip directed-broadcast
   bridge-group 6
  !
  interface Port-channel1.10
   encapsulation dot1Q 10
   no ip redirects
   no ip directed-broadcast
   bridge-group 10
  !
  interface GigabitEthernet1
   no ip address
   no ip directed-broadcast
  !
  interface GigabitEthernet1.1 设置第一个千兆口的第一个子端口
   encapsulation dot1Q 1 native 使第一个子端口划分为vlan 1中
   no ip redirects
   no ip directed-broadcast
   bridge-group 1
  !
  interface GigabitEthernet1.2 设置第一个千兆口的第二个子端口
   encapsulation dot1Q 2 把第二个子端口划分为 vlan 2中(注:第2个子端口必须划分到vlan 2,不能划分到其他vlan否则,就无效)
   no ip redirects
   no ip directed-broadcast
   bridge-group 2
  !
  interface GigabitEthernet1.3
   encapsulation dot1Q 3
   no ip redirects
   no ip directed-broadcast
   bridge-group 3
  !
  interface GigabitEthernet1.4
   encapsulation dot1Q 4
   no ip redirects
   no ip directed-broadcast
   bridge-group 4
  !
  interface GigabitEthernet1.5
   encapsulation dot1Q 5
   no ip redirects
   no ip directed-broadcast
   bridge-group 5
  !
  interface GigabitEthernet1.6
   encapsulation dot1Q 6
   no ip redirects
   no ip directed-broadcast
   bridge-group 6
  !
  interface GigabitEthernet1.10
   encapsulation dot1Q 10
   no ip redirects
   no ip directed-broadcast
   bridge-group 10

  !
  interface GigabitEthernet2
   no ip address
   no ip directed-broadcast
  !
  interface GigabitEthernet2.1
   encapsulation dot1Q 1 native
   no ip redirects
   no ip directed-broadcast
   bridge-group 1
  !
  interface GigabitEthernet2.2
   encapsulation dot1Q 2
   no ip redirects
   no ip directed-broadcast
   bridge-group 2
  !
  interface GigabitEthernet2.3
   encapsulation dot1Q 3
   no ip redirects
   no ip directed-broadcast
   bridge-group 3
  !
  interface GigabitEthernet2.4
   encapsulation dot1Q 4
   no ip redirects
   no ip directed-broadcast
   bridge-group 4
  !
  interface GigabitEthernet2.5
   encapsulation dot1Q 5
   no ip redirects
   no ip directed-broadcast
   bridge-group 5
  !
  interface GigabitEthernet2.6
   encapsulation dot1Q 6
   no ip redirects
   no ip directed-broadcast
   bridge-group 6
  !
  interface GigabitEthernet2.10
   encapsulation dot1Q 10
   no ip redirects
   no ip directed-broadcast
   bridge-group 10
  !
  interface GigabitEthernet3
   no ip address
   no ip directed-broadcast
  !
  interface GigabitEthernet3.1
   encapsulation dot1Q 1 native
   no ip redirects
   no ip directed-broadcast
   bridge-group 1
  !
  interface GigabitEthernet3.2
   encapsulation dot1Q 2
   no ip redirects
   no ip directed-broadcast
   bridge-group 2
  !
  interface GigabitEthernet3.3
   encapsulation dot1Q 3
   no ip redirects
   no ip directed-broadcast
   bridge-group 3
  !
  interface GigabitEthernet3.4
   encapsulation dot1Q 4
   no ip redirects
   no ip directed-broadcast
   bridge-group 4
  !
  interface GigabitEthernet3.5
   encapsulation dot1Q 5
   no ip redirects
   no ip directed-broadcast
   bridge-group 5
  !
  interface GigabitEthernet3.6
   encapsulation dot1Q 6
   no ip redirects
   no ip directed-broadcast
   bridge-group 6
  !
  interface GigabitEthernet3.10
   encapsulation dot1Q 10
   no ip redirects
   no ip directed-broadcast
   bridge-group 10
  !
  interface GigabitEthernet4
   no ip address
   no ip directed-broadcast
  !
  interface GigabitEthernet4.1
   encapsulation dot1Q 1 native
   no ip redirects
   no ip directed-broadcast
   bridge-group 1
  !
  interface GigabitEthernet4.2
   encapsulation dot1Q 2
   no ip redirects
   no ip directed-broadcast
   bridge-group 2
  !
  interface GigabitEthernet4.3
   encapsulation dot1Q 3
   no ip redirects
   no ip directed-broadcast
   bridge-group 3
  !
  interface GigabitEthernet4.4
   encapsulation dot1Q 4
   no ip redirects
   no ip directed-broadcast
   bridge-group 4
  !
  interface GigabitEthernet4.5
   encapsulation dot1Q 5
   no ip redirects
   no ip directed-broadcast
   bridge-group 5

  !
  interface GigabitEthernet4.6
   encapsulation dot1Q 6
   no ip redirects
   no ip directed-broadcast
   bridge-group 6
  !
  interface GigabitEthernet4.10
   encapsulation dot1Q 10
   no ip redirects
   no ip directed-broadcast
   bridge-group 10
  !
  interface GigabitEthernet5
   no ip address
   no ip directed-broadcast
  !
  interface GigabitEthernet5.1
   encapsulation dot1Q 1 native
   no ip redirects
   no ip directed-broadcast
   bridge-group 1
  !
  interface GigabitEthernet5.2
   encapsulation dot1Q 2
   no ip redirects
   no ip directed-broadcast
   bridge-group 2
  !
  interface GigabitEthernet5.3
   encapsulation dot1Q 3
   no ip redirects
   no ip directed-broadcast
   bridge-group 3
  !
  interface GigabitEthernet5.4
   encapsulation dot1Q 4
   no ip redirects
   no ip directed-broadcast
   bridge-group 4
  !
  interface GigabitEthernet5.5
   encapsulation dot1Q 5
   no ip redirects
   no ip directed-broadcast
   bridge-group 5
  !
  interface GigabitEthernet5.6
   encapsulation dot1Q 6
   no ip redirects
   no ip directed-broadcast
   bridge-group 6
  !
  interface GigabitEthernet5.10
   encapsulation dot1Q 10
   no ip redirects
   no ip directed-broadcast
   bridge-group 10
  !
  interface GigabitEthernet6
   no ip address
   no ip directed-broadcast
   channel-group 1
  !
  interface GigabitEthernet7
   no ip address
   no ip directed-broadcast
   channel-group 1
  !
  interface GigabitEthernet8
   no ip address
   no ip directed-broadcast
  !
  interface GigabitEthernet8.1
   encapsulation dot1Q 1 native
   no ip redirects
   no ip directed-broadcast
   bridge-group 1
  !
  interface GigabitEthernet8.2
   encapsulation dot1Q 2
   no ip redirects
   no ip directed-broadcast
   bridge-group 2
  !
  interface GigabitEthernet8.3
   encapsulation dot1Q 3
   no ip redirects
   no ip directed-broadcast
   bridge-group 3
  !
  interface GigabitEthernet8.4
   encapsulation dot1Q 4
   no ip redirects
   no ip directed-broadcast
   bridge-group 4
  !
  interface GigabitEthernet8.5
   encapsulation dot1Q 5
   no ip redirects
   no ip directed-broadcast
   bridge-group 5
  !
  interface GigabitEthernet8.6
   encapsulation dot1Q 6
   no ip redirects
   no ip directed-broadcast
   bridge-group 6
  !
  interface GigabitEthernet8.10
   encapsulation dot1Q 10
   no ip redirects
   no ip directed-broadcast
   bridge-group 10
  !
  interface BVI10 (远程治理登陆ip地址)
   ip address 192.168.1.251 255.255.255.0
   no ip directed-broadcast
  !
  ip classless
  !
  bridge 1 PRotocol ieee 配置桥接协议
  bridge 2 protocol ieee
  bridge 3 protocol ieee
  bridge 4 protocol ieee
  bridge 5 protocol ieee

  bridge 6 protocol ieee
  bridge 10 protocol ieee
   bridge 10 route ip
  !
  line con 0
   transport input none
  line aux 0
  line vty 0 4
   password cisco
   login local
  !
  end
  
  假如,6509上面增加新的vlan 比如:增加 vlan 20,则在4908g上需要增加的配置的命令是
  在每个千兆口上和快速通道口上划分一个新的子端口,
   interface GigabitEthernet1.20
  encapsulation dot1Q 20
  bridge-group 20
  每个端口都参照这样配置。
  
  在router(config)#状态下,加入以下命令:
  bridge 20 protocol ieee
  按照这种方式就可以增加vlan
  
  cisco 4908g-L3 三层交换机,每个端口均支持三层交换! 第三层交换12 Mpps
  为布线室和数据中心提供高性能、中等密度的、10/100/1000M以太网模块交换平台。