CCNA网络小菜鸟笔记

1/6/2008来源:Cisco网络人气:7310

第一章, 网际互连
  
  把一个大的网络划分为一些小的网络就称为网络分段,这些工作由路由器,交换机和网桥来按成。
  引起LAN通信量出现足赛的可能原因如下:
  
  1. 在一个广播域中有太多的主机
  2. 广播风暴
  3. 组播
  4. 低的带宽
  
  路由器被用来连接各种网络,并将数据包从一个网络路由到另一个网络。
  默认时,路由器用来分隔广播域,所谓广播域,是指王端上所有设备的集合,这些设备收听送往那个王端的所有广播。尽管路由器用来分隔广播域,但重要的是要记住,路由器也用来分隔冲突域。
  在网络中使用路由器有两个好处:
  1. 默认时路由器不会转发广播。
  2. 路由器可以根据第三层(网络层)信息对网络进行过滤。
  默认时,交换机分隔冲突域。这是一个以太网术语,用来描述:某个特定设备在网段上发送一个数据包,迫使同一个网段上的其他设备都必须主要道这一点。在同一时刻,假如两个不同的设备试图发送数据包,就会产生冲突域,此后,两个设备都必须重新发送数据包。
  
  网际互连模型
  当网络刚开始出现时,典型情况下,只能在同一制造商的计算机产品之间进行通信。在20世纪70年代后期,国际标准化组织创建了开放系统互联参考模型,也就是OSI七层模型。
  OSI模型时为网络而构建的最基本的层次结构模型。下面是分层的方法,以及怎样采用分层的方法来排除互联网络中的故障。
  
  分层的方法
  参考模型时一种概念上的蓝图,描述了通信是怎样进行的。他解决了实现有效通信所需要的所有过程,并将这些过程划分为逻辑上的组,称为层。
  
  参考模型的优点
  OSI模型时层次化的,任何分层的模型都有同样的好处和优势。
  采用OSI层次模型的优点如下,当然不仅仅是这些:
  1. 通过网络组件的标准化,答应多个提供商进行开发。
  2. 答应各种类型网络硬件和软件相互通信。
  3. 防止对某一层所作的改动影响到其他的层,这样就有利于开发。
  
  OSI参考模型
  OSI模型规范重要的功能之一,是帮助不能类型的主机实现相互之间的数据传输。
  
  OSI模型有7个不同的层,分为两个组。上面三层定义了中断系统中的应用程序将被彼此通信,以及如何与用户通信。下面4层定义了三怎样进行端到端的数据传输。
  
  下面4层定义了怎样通过物力电缆或者通过交换机和路由器进行数据传输。
  
  传输层:
  1. 提供可靠或不可靠的传输
  2. 在重传之前执行错误纠正
  
  网络层:
  1. 提供逻辑寻址,以便进行路由选择.
  数据链路层:
  1. 将数据包组合为字节,字节组合为帧
  2. 使用MAC地址提供对介质的访问
  3. 执行错误检测,但不纠正
  
  物理层:
  1. 在设备之间传输比特流
  2. 制定电压大小、线路速率和电缆的引脚数
  
  工作在OSI模型的所有7层的网络设备包括:
  1. 网络治理系统(NMS)
  2. WEB和应用程序服务器
  3. 网关(非默认网关)
  4. 网络主机
  
  OSI参考模型的7层和各层的功能
  1. application layer 文件、打印、消息、数据库和应用程序
  2. PResentation layer 数据加密、压缩和转换服务
  3. session layer 会话控制
  4. Transport layer 端到端连接
  5. Network layer 路由选择
  6. Data Link layer 数据组合成帧
  7. Physical layer 物理拓扑
  
  应用层:OSI模型的应用层是用户与计算机进行实际通信的地方。
  
  表示层:表示层因它的用途而得名:它为应用层提供数据,并负责数据转换和代码的格式化。
  
  会话层:会话层负责建立、治理和终止表示层实体之间的会话连接。
  
  传输层:传输层将数据分段并重组为数据流。
  
  网络层:网络层负责设备的寻址,跟踪网络中设备的位置,并决定传送数据的最佳路径,这意味着网络层必须在位于不同地区的互联设备之间传输数据流。
  
  数据链路层:数据链路层提供数据的物理传输,并处理出错通知、网络拓扑和流量控制。
  
  物理层:物理层是最低层,物理层的功能有两个:发送和接收位流。
  
  以太网(ETHERNET)组网
  以太网采用竞争型的介质访问方法,答应网络上的所有主机共享同一条链路的带宽。
  以太网采用带冲突检测的载波监听多路访问(CSMA/CD)技术。
  采用CSMA/CD协议的网络将承受巨大的冲突压力,包括:
  1. 延迟
  2. 低的吞吐量
  3. 拥塞
  
  半双工和全双工以太网
  半双工以太网在原始的802.3以太网中定义,它只适用一对线缆,数字信号在线路上是双向传输的。
  半双工以太网也采用CSMA/CD协议,以防止产生冲突,假如产生了冲突,就答应重传。
  全双工以太网是用两对电缆线,而不失向半双工方式那样是用一对电缆线。
  
  全双工以太网可以用于下列3种情况:
  1. 交换机到主机的连接
  2. 交换机到交换机的连接
  3. 使用交叉电缆的从主机到主机的连接
  
  以太网的数据链路层
  以太网的数据链路层负责以太网寻址,通常成其为硬件寻址或MAC寻址。
  
  有四种不同类型的以太网帧可用:
  1. Ethernet_II
  2. IEEE 802.3
  3. IEEE 802.2

  4. SNAP
  
  Ethernet寻址
  它采用截至访问控制(Media access Control, MAC)地址进行寻址,MAC地址被烧入每个以太网网卡中。MAC地址也叫硬件地址,它采用48位(6个字节)的十六进制格式。
  Ethernet帧
  数据链路层负责将位组合成字节,并将字节组合成帧。
  
  802.3帧的格式:
  前导(Preambl)
  帧起始定界符/同步(Start Frame Delimiter,SFD)/Synch
  目的地址(Destination Address,DA)
  源地址(Source Address,SA)
  长度(Length)或类型(Type)字段
  数据(Data)
  帧效验序列(Frame Check Sequence,FCS)
  Ethernet物理层
  Ethernet最早由DIX实现。这是一种传输速率为10Mb/s的网络,其物理介质可以是同轴电缆、双绞线和光纤。
  下面是原始的IEEE 802.3标准:
  10Base2
  10Base5
  10BaseT
  下面是扩展的IEEE 802.3标准:
  100BaseTX
  100BaseFX
  1000BaseCX
  1000BaseT
  1000BaseSX
  1000BaseLX
  
  Ethernet电缆的连接
  可用的Ethernet电缆类型有:
  1. 直通电缆
  2. 交叉电缆
  3. 反转电缆
  
  直通电缆:
  1. 主机到交换机或集线器
  2. 路由器到交换机或集线器
  
  交叉电缆:
  1. 交换机到交换机
  2. 集线器到集线器
  3. 主机到主机
  4. 集线器到交换机
  5. 路由器直连到主机
  
  反转电缆:
  这种类型的电缆不是用来将各种Ethernet部件连接起来,而是反转的Ethernet电缆来实现从主机到路由器控制台串行通信(com)端口的连接。
  无线联网(Wireless Networking)
  下面是各种类型的无线网络
  1. 窄带无线(Narrowband Wireless LAN)
  2. 个人通信服务(PCS)
  3. 窄带PCS
  4. 宽带PCS
  5. 卫星
  6. 红外无线LAN
  7. 扩频无线LAN
  
  数据封装
  当主机向其他的设备跨网络传输数据时,数据就要进行封装,就是在OSI模型的每一层加上协议信息。每一层只与接收设备上相应的对等层进行通信。
  Cisco的3层(层次)模型
  Cisco的层次模型可以用来帮助设计,实现核维护可扩展的、可靠的、性能价格比高的层次化的互联网络。
  Cisco定义了3个层次,下面是3个层次和他们的典型功能:
  1. 核心层:骨干
  核心层就是网络的中心。他位于顶层,负责可靠而迅速的传输大量的数据流。网络核心层的唯一意图是,尽可能快的交换数据流。
  2. 分配层:路由
  分配层有时也称为工作组层,它是接入层和核心层之间的通信点。分配层主要功能是提供路由、过滤和WAN接入,假如需要的话,他还决定数据报可以怎样对核心层进行访问。
  3. 接入层:交换
  接入层控制用户和工作组对互联网络资源的访问。接入层也称桌面层。大多数用户所需要的网络资源将在本地获得,分配层处理远程服务的数据流。
  
  第二章, 因特网协议
  
  TCP/ip和DoD模型
  DoD模型是OSI模型的一个基本的、浓缩的版本,他只有四个层次,而不是七个:
  1. 过程/应用层
  2. 主机到主机层
  3. 因特网层
  4. 网络接入层
  在DoD模型的过程/应用层中包含了大量的协议它集成了各种应用和功能来省城一个可以和OSI模型中三个高层(应用层、表示层和会话层)相对应的集合。
  
  过程/应用层协议
  1. Telnet
  它答应一个用户在一个远程的客户机上,访问另一台机器上的资源。
  2. FTP
  文件传输协议实际上就是传输文件的协议,它可以应用在任意两个主机之间。
  3. TFTP
  简单文件传输协议是FTP的简化版本,只有在你确切地知道想到得到的文件名及他的准确位置时,才可有选择的使用TFTP。
  4. NFS
  网络文件系统在文件共享中是一个非凡的协议珍宝。他答应两个不同类型的文件系统实现互操作。
  5. SMTP
  简单又见传输协议,是对应于我们普遍使用的被称为E-mail的应用,他描述了邮件投递中的假脱机、排列及方法。
  6. LPD
  行式打印机守护进程协议,使被设计用于实现打印机共享的。
  7. X Window
  为客户-服务器业务而设计,X Window定义了一个编写基于图形化用户界面(GUI)的客户-服务器应用程序的协议
  8. SNMP
  简单网络治理协议采集并使用一些有价值的网络信息。
  9. DNS
  域名服务可以解析主机名,非凡是Internet名。
  10. DHCP/BootP
  动态主机配置协议可以为主机分配IP地址。
  
  主机到主机层协议
  主机到主机层的主要目的,是将上层的应用从网络传输的复杂性中屏蔽出来。

  在这里将描述着一层上的两个协议:
  1. 传输控制协议(TCP)
  2. 用户数据报协议(UDP)
  
  传输控制协议
  传输控制协议通常是从应用程序中得到大段的信息数据,然后将它分割成若干个数据段。
  TCP的数据段格式
  TCP报头是一个20字节长的段,在带有选项时可以达到24个字节。
  在TCP数据段中包含如下字段:
  1. 源端口
  2. 目的端口
  3. 序列号
  4. 确认应答号
  5. 偏移量
  6. 保留
  7. 代码位
  8. 窗口
  9. 效验和
  10. 紧急指针
  11. 选项
  12. 数据
  
  用户数据报协议
  假如将用户数据报协议(UDP)与TCP座一个比较,UDP基本是一个缩小规模的经济化模式,有时也被称为瘦协议。
  UDP数据段的格式
  在UDP数据段中包含了下列字段:
  1. 源端口
  2. 目的端口
  3. 数据段长度
  4. CRC
  5. 数据
  
  主机到主机层的重要概念
  TCP和UDP的重要功能
  TCP UDP
  排序 无序
  可靠 不可靠
  面向连接 无连接
  虚电路 低开销
  确认 无确认
  窗口流量确认 没有窗口或流量控制
  
  端口号
  TCP和UDP都必须使用端口号来与上层进行通信,因为他们需要跟踪同时使用网络进行的不同的会话过程。不使用带有众所周知的端口号的应用程序的虚电路时从一个指定的范围中随机地指定端口号。
  下面解释了可以使用的不同的端口号:
  1. 低于1024的端口号被称为众所周知的端口号,他们是由RFC 3232所定义。
  2. 大于1024及1024的端口号被上层用来建立与其他主机的会话,并且在TCP数据段中被TCP用来作为源方和目的方的地址。
  
  因特网层协议
  在DoD的模型中,设置因特网层有两个主要的理由:路由及为上层提供一个简单的网络接口。
  没有任何一个其他的高层或低层协议会涉及到任何有关路由的功能,这个复杂和重要的任务是完全属于因特网层。
  因特网层协议:
  1. 因特网协议(IP)
  2. 因特网控制报文协议(ICMP)
  3. 地址解析协议(ARP)
  4. 逆向地址解析协议(RARP)
  
  因特网协议(IP)
  因特网协议其实质就是因特网层。其他的协议仅仅是建在离其基础上用于支持IP协议的。
  IP是从主机到主机层处接受数据段的,在需要时再将他们组合成数据报(数据包),然后接收方的IP再重新组合数据报为数据段。每个数据报都被指定了发送者和接收者的IP地址。每个接收了数据报的路由器都是基于数据包的目的IP地址来决定路由的。
  构成IP报头的字段如下:
  1. 版本 4
  2. 报头长度(HLEN) 4
  3. IP优先位或ToS 8
  4. 总长度 16
  5. 标识 16
  6. 标志 3
  7. 分段偏移 13
  8. TTL(存活期) 8
  9. 协议 8
  10. 报头和效验和 16
  11. 源IP地址 32
  12. IP选项 0或32
  13. 数据 可变
  注:后面的数字表示长度
  
  在IP报头的协议字段中可能发现的协议
  协议 协议号
  ICMP 1
  IGRP 9
  EIGRSP 88
  OSPF 89
  IPv6 41
  GRE 47
  IPX in IP 111
  Layer-2 tunnel(L2TP) 115
  
  因特网控制报文协议
  因特网控制报文协议(ICMP)工作在网络层,它被IP用于提供许多不同的服务。ICMP是一个治理性协议,并且也是一个IP信息服务的提供者。他的信息是被作为IP数据报来传送的。
  下面是与ICMP相关的一些常见的事件和信息:
  1. 目的不可达 假如路由器不能再向前发送某个IP数据报,这是路由器会使用ICMP来传送一个信息返回给发送端,来通告这一情况。
  2. 缓冲区满 假如路由器用于接收输入数据的内存缓冲区已经满了,他将会使用ICMP向外发送这个信息直道拥塞解除。
  3. 跳 每个ip数据报都被分配了一个所答应经过路由器个数的数值,被称为跳(hop)。
  4. Ping Ping(即数据包的因特网探测)使用ICMP回应信息在互联网络上检查计算机间物理连接的连通性。
  5. Traceroute Traceroute是通过使用ICMP的超时机制,来发现一个数据报在穿越互联网络时它所经历的路径。
  
  地址解析协议(ARP)
  地址解析协议(ARP)可以由已知主机的IP地址,在网络上查找到他的硬件地址。
  逆向地址解析协议(RARP)
  当一台误判计算机被用做IP主机时,它没有办法在其初始化时了解自己的IP地址。但是他可以知道自己的MAC地址。逆向地址解析协议(RARP)可以通过发送一个包含有无盘主机MAC地址的数据包,来询问与此MAC地址相对应的IP地址。
  
  二进制、十进制和十六进制的转换
  二进制到十进制的记忆表
  二进制取值 十进制取值
  10000000 128
  11000000 192
  11100000 224
  11110000 240
  11111000 248
  11111100 252
  11111110 254
  11111111 255
  
  十六进制到二进制到十进制表
  十六进制值 二进制值 十进制值
  0 0000 0
  1 0001 1
  2 0010 2
  3 0011 3
  4 0100 4
  5 0101 5
  6 0110 6
  7 0111 7
  8 1000 8
  9 1001 9
  A 1010 10
  B 1011 11
  C 1100 12
  D 1101 13
  E 1110 14
  F 1111 15
  
  IP寻址
  IP地址是IP网络上每个计算机的数字化标识符。它指明了在此网络上某个设备的位置。

  IP地址是一个软件地址,而不是硬件地址,后者是被硬烧录到网卡(NIC)中的并且主要是用于在本地网络上定位主机的。
  
  IP术语
  位 一位就是一个数字,要么是1,要么是0
  字节 一个字节可以是7位或8位
  八位位组 就是8位,一个最基本的8位二进制数
  网络地址 它是用来指定数据包所要传送的远程网络
  广播地址 被应用程序或主机用来将信息发送给网络上所有节点的地址,我们称之为广播地址。
  
  分层的IP寻址方案
  一个IP地址包含有32位的信息。这些位通常被分割为四个部分,被称为八位位组或字节,每一部分包含一个字节(8个位)。
  可以使用下面3种不同的方式来描述一个IP地址:
  1. 点分十进制,如172.16.30.56
  2. 二进制,10101100.00010000.00011110.00111000
  3. 十六进制,AC.10.1E.38
  所有例子表示的都是同一个IP地址
  
  网络寻址
  网络地址唯一地制定了每个网络。在同一网络中的美态计算机都共享相同的网络地址,并用它来作为自己IP地址的一部分。
  节点地址是在一个网络中用来标识每台计算机的,它是一个唯一的标识符。这个地址的节点部分必须是唯一的,因为相对于网络而言它是用来独立的标识指定计算机的。
  因特网的设计者决定根据网络的大小来创建网络的类别。
  三个网络类别的总结
  8位 8位 8位 8位
  类A 网络 主机 主机 主机
  类B 网络 网络 主机 主机
  类C 网络 网络 网络 主机
  类D 组播
  类E 研究
  
  网络地址范围:A类
  00000000=0
  01111111=127
  网络地址范围:B类
  10000000=128
  10111111=191
  网络地址范围:C类
  11000000=192
  11011111=223
  网络地址范围:C类和E类
  介于224和255之间的地址是被保留用作D类和E类网络的。D类是用于组播的地址(224到239),而E类(240到255)是被用于科学实验用途的。
  网络地址:用于非凡目的
  有些IP地址是被保留用于某些非凡目的的,网络治理员不能将这些地址分配给节点。
  
  一些非凡的IP地址:
  1.IP地址127.0.0.1:本地回环(loopback)测试地址
  2.广播地址:255.255.255.255
  3.IP地址0.0.0.0:代表任何网络
  4.网络号全为0:代表本网络或本网段
  5.网络号全为1:代表所有的网络
  6.节点号全为0:代表某个网段的任何主机地址
  7.节点号全为1:代表该网段的所有主机
  
  一些私有地址的范围:
  1.A类地址中:10.0.0.0到10.255.255.255.255
  2.B类地址中:172.16.0.0到172.31.255.255
  3.C类地址中:192.168.0.0到192.168.255.255
  
  广播地址:
  1.层2广播:FF.FF.FF.FF.FF.FF,发送给LAN内所有节点
  2.层3广播:发送给网络上所有节点
  3.单播(unicast):发送给单独某个目标主机
  4.多播:由1台主机发出,发送给不同网络的许多节点
  
  第三章, IP子网划分和变长子网掩码(VLSM)
  
  子网划分基础
  这里给出了子网划分的若干个好处:
  1. 缩减网络流量
  2. 优化网络性能
  3. 简化治理
  4. 可以更为灵活的形成大覆盖范围的网络
  
  如何创建子网
  要创建子网,就需要从IP地址的主机部分中借出一定的位,并且保留他们用来定义子网地址。这一位着用于主机的位减少,所以子网越多,可用于定义主机的位越少。
  下面就是实现划分子网的步骤:
  1. 确认所需要的网络ID数:
  每个子网需要有一个网络号
  每个广域网连接需要有一个网络号
  2. 确认每个子网中所需要的主机ID数:
  每台TCP/IP主机需要一个主机地址
  路由器的每个接口需要一个主机地址
  3. 基于以上需要,创建如下内容:
  为整个网络设定一个子网掩码
  为每个物理望断设定一个不同的子网ID
  为每个子网确定主机的合法地址范围
  子网掩码
  为了保证所配置的子网地址可以工作,在网络上每台计算机都必须知道自己主机地址中的哪一部分是被用来表示子网地址的。这可以通过在每台计算机上制定一个子网掩码来完成。
  网络治理员是用1和0的组合来创建一个32位的子网掩码。子网掩码中1的位置表示是网络或子网的地址部分。
  不是所有的网络都需要子网掩码,有些主机使用默认的子网掩码。这基本上与认为一个网络不需要子网地址是相同的。
  默认的子网掩码
  类型 格式 默认子网掩码
  A Network.node. node. Node 255.0.0.0
  B Network. Network. node. Node 255.255.0.0
  C Network. Network. Network. node 255.255.255.0
  
  无类的内部域路由(CIDR)
  子网掩码 CIDR值
  255.0.0.0 /8
  255.127.0.0 /9
  255.192.0.0 /10
  255.224.0.0 /11
  255.240.0.0 /12
  255.248.0.0 /13
  255.252.0.0 /14
  255.254.0.0 /15
  255.255.0.0 /16
  255.255.128.0 /17
  255.255.192.0 /18
  255.255.224.0 /19
  255.255.240.0 /20
  255.255.248.0 /21
  255.255.252.0 /22
  255.255.254.0 /23
  255.255.255.0 /24
  255.255.255.128 /25
  255.255.255.192 /26
  255.255.255.224 /27
  255.255.255.240 /28
  255.255.255.248 /29
  255.255.255.252 /30

  
  C类地址的子网划分
  在一个C类地址中,只有八位是可以用来定义主机的。记住,子网位必须是由左到右进行定义的,这中间,不能跳过某些位。也就是说,C类子网掩码只能是:
  二进制 十进制 速记
  10000000 128 /25
  11000000 192 /26
  11100000 224 /27
  11110000 240 /28
  11111000 248 /29
  11111100 252 /30
  11111110 254 /31(无效)
  
  第四章, Cisco IOS简介
  
  路由器IOS
  IOS是被用来传送网络服务并启动网络应用的。
  Cisco路由器的IOS软件负责完成重要的工作:
  1. 加载网络协议和功能
  2. 在设备间连接高速流量
  3. 在控制访问中添加安全性防止未授权的网络使用
  4. 为简化网络的增长和冗余备份,提供可缩放性
  5. 为连接到网络中的资源,提供网络的可靠性
  
  连接到Cisco路由器
  可以通过连接到Cisco路由器来进行路由器的设置、配置的验证及统计数据的审核。
  通常是使用通过控制台端口进行连接。控制台接口一般是一个RJ-45的连接器,位于路由器背面,默认的时候,没有口令要求。
  
  启动路由器
  初次启动一个Cisco路由器时,它将运行一个开机自检过程。假如通过,他将在闪存中查找IOS系统,假如有IOS文件存在则执行装载操作。闪存世一个电子可擦写变成的制度存储器。然后,IOS将继续加载并查找一个合法的配置文件,它默认时是存储在NVRAM中。
  当路由器被首次引导或重新装载时,会出现的信息:
  System Bootstrap, Version 11.0(10c), SOFTWARE
  Copyright (c) 1986-1996 by cisco Systems
  2500 processor with 14336 Kbytes of main memory
  这是一台2501路由器启动时的信息
  第一行写了,IOS版本是11.0
  第二行是CISCO的版权信息
  第三行行是内存的大小
  路由器启动以后,会出现一个提示
  Would you like to enter the initial configuration dialog [yes/no]: n
  假如选择yes,将进入setup模式,选择No我们将进入扩展设置模式。
  Setup模式只配置购治理系统使用的连接性能,而扩展设置会答应你配置更多的内容。
  
  命令行界面
  正式因为命令行界面(CLI)是如此的灵活方便,所以他是配置路由器的最佳方式。
  要使用CLI,只需要在初始化配置对话框窗口中输入NO。
  
  登陆到路由器
  Router> 这就是用户模式,通常用来查看统计信息的
  在特许模式中你可以查看并修改Cisco路由器的配置,但要进入此模式需要使用enable命令
  具体步骤如下:
  Router>
  Router>enable
  Router#
  ---------------------
  现在得到一个Router#提示符,表明已经在特许模式中了,在这里可以修改路由器的配置。
  在这里可以通过使用disable命令,从特许模式中返回用户模式。
  Router#disable
  Router>
  在用户模式里,可以用logout命令来退出控制台操作:
  Router>logout
  Router con0 is now available
  Press RETURN to get started.
  也可以在特许模式下键入logout或exit来退出:
  Router>enable
  Router#logout
  Router con0 is now available
  Press RETURN to get started.
  路由器模式概述
  要从CLI上进行配置,可能会需要用configure terminal命令进入全局模式才能修改当权运行配置中的内容。你也可以在特许模式下键入config,然后按Enter键以默认方式进入全局模式。
  Router#config
  Configuring from terminal, memory, or network [terminal] (Enter)
  Enter configuration commands, one per line. End with CNTL/Z.
  Router(config)#
  CLI提示符
  在配置路由器时,理解所碰到的不同提示符的含义,是非常重要的。
  
  接口
  在修改接口配置,需要在全局模式下使用interface命令:
  Router(config)#interface
  Async Async interface
  BVI Bridge-Group Virtual Interface
  CTunnel CTunnel interface
  Dialer Dialer interface
  Ethernet IEEE 802.3
  Group-Async Async Group interface
  Lex Lex interface
  Loopback Loopback interface
  Multilink Multilink-group interface
  Null Null interface
  Serial Serial
  Tunnel Tunnel interface
  Vif PGM Multicast Host interface
  Virtual-Template Virtual Template interface
  Virtual-TokenRing Virtual TokenRing
  range interface range command

  Router(config)#int Serial 0
  Router(config-if)#
  Router(config-if)# 当提示符改变成这个的时候,说明你已经处在接口配置模式中了。
  
  子接口
  子接口答应尼在路由器中创建逻辑接口。在子接口中,提示符会改变为Router(config-subif)#
  Router(config)#int s0.
  <0-4294967295> Serial interface number
  行命令
  要配置用户模式口令,是用Line命令
  Router(config)#line
  <0-6> First Line number
  aux Auxiliary line
  console Primary terminal line
  vty Virtual terminal
  路由协议配置
  要配置rip或igrp这样的路由协议,需要使用(config-router)#提示符:
  Router(config)#router
  bgp Border Gateway Protocol (BGP)
  egp Exterior Gateway Protocol (EGP)
  eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
  igrp Interior Gateway Routing Protocol (IGRP)
  isis ISO IS-IS
  iso-igrp IGRP for OSI networks
  mobile Mobile routes
  odr On Demand stub Routes
  ospf Open Shortest Path First (OSPF)
  rip Routing Information Protocol (RIP)
  Router(config)#router rip
  Router(config-router)#
  编辑和帮助功能
  可以使用Cisco高级的编辑功能来帮助配置路由器。
  在任意提示符下键入一个问号。(?),都将会得到在当前提示符下所有命令的清单。
  下面是查找以某个字母开头的快捷方式命令:
  Router(config)#i
  interface ip ipx isis
  在一个命令串中找下一个命令,可以先键入前面的命令然后输入一个问号:
  Router(config)#interface
  Async Async interface
  BVI Bridge-Group Virtual Interface
  CTunnel CTunnel interface
  Dialer Dialer interface
  Ethernet IEEE 802.3
  Group-Async Async Group interface
  Lex Lex interface
  Loopback Loopback interface
  Multilink Multilink-group interface
  Null Null interface
  Serial Serial
  Tunnel Tunnel interface
  Vif PGM Multicast Host interface
  Virtual-Template Virtual Template interface
  Virtual-TokenRing Virtual TokenRing
  range interface range command
  
  Router(config)#interface serial
  <0-1> Serial interface number
  
  Router(config)#interface serial 0
  <cr>
  Router(config-if)#
  
  
  
  增强的编辑命令
  命令 含义
  CTRL+A 移动光标到本行的开始处
  CTRL+E 移动光标到本行的结尾处
  ESC+B 往回移动一个字
  CTRL+F 向前移动一个字符
  ESC+F 向前移动一个字
  CTRL+D 删除某个单一字符
  BACKSPACE 删除某个单一字符
  CTRL+R 重新显示一行
  CTRL+U 删除一行
  CTRL+W 删除一个字
  CTRL+Z 结束配置模式并返回执行(EXEC)模式
  TAB 完成输入一个命令
  
  获取基本的路由信息
  Router#sh version
  Cisco Internetwork Operating System Software
  IOS (tm) 2500 Software (C2500-JS-L), Version 12.2(27), RELEASE SOFTWARE (fc3)
  Copyright (c) 1986-2004 by cisco Systems, Inc.
  Compiled Tue 02-Nov-04 22:01 by kellmill
  Image text-base: 0x0307D390, data-base: 0x00001000
  
  ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE
  BOOTLDR: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE SOFTWARE (fc1)
  
  Router uptime is 17 minutes
  System returned to ROM by power-on
  System image file is "Flash:c2500-js-l.122-27.bin"
  
  cisco 2500 (68030) processor (revision D) with 16384K/2048K bytes of memory.
  Processor board ID 02096577, with hardware revision 00000000
  Bridging software.

  X.25 software, Version 3.0.0.
  SuperLAT software (copyright 1990 by Meridian Technology Corp).
  TN3270 Emulation software.
  1 Ethernet/IEEE 802.3 interface(s)
  2 Serial network interface(s)
  32K bytes of non-volatile configuration memory.
  16384K bytes of processor board System flash (Read ONLY)
  
  Configuration register is 0x2142
  
  
  设置口令
  启用口令
  可以在全局配置模式下设置启用口令:
  Router(config)#enable
  last-resort Define enable action if no TACACS servers respond
  passWord Assign the privileged level password
  secret Assign the privileged level secret
  use-tacacs Use TACACS to check enable passwords
  辅助口令
  要配置辅助接口口令,需要进入到全局配置模式并输入Line aux 。
  Router(config)#line aux
  <0-0> First Line number
  
  Router(config)#line aux 0
  Router(config-line)#password 12345
  Router(config-line)#login
  Router(config-line)#
  
  控制台口令
  要设置控制台口令,使用line console 0命令。
  Router(config)#line console 0
  Router(config-line)#password 12345
  Router(config-line)#login
  
  Telnet口令
  要为Telnet访问路由器设置用户模式口令,是用line vty命令。
  Router(config)#line vty 0
  <1-197> Last Line number
  <cr>
  
  Router(config)#line vty 0 4
  Router(config-line)#password 12345
  Router(config-line)#login
  Router(config-line)#
  加密你的口令
  在默认时只有启用加密口令是加密的,为了安全,需要手工配置用户模式口令和启用口令。
  要实现口令加密,需要在全局模式下使用service password-encryption命令。
  Router#config t
  Enter configuration commands, one per line. End with CNTL/Z.
  Router(config)#service password-encryption
  Router(config)#
  
  标志区
  使用标志区是为那些拨号到你的互联网络中的用户提供了一个安全的提示。
  在Cisco路由器上设置一个标志区,这样当任一用户登录到路由器上或远程访问路由器时,标志区显示你希望他们看到的信息。
  设置标志区,是用banner motd命令
  Router(config)#banner motd #
  Enter TEXT message. End with the character '#'.
  Welcome to Hu Lian Shen Zhou
  #
  Router(config)#exit
  现在显示出来的就是刚才设置的标志区:
  Welcome to Hu Lian Shen Zhou
  User Access Verification
  Password:
  
  路由器接口
  接口配置是路由器很重要的配置,没有接口,路由器整个是没用的。
  不同的路由器使用不同的方式来选择接口的使用。
  Router(config)#int
  Async Async interface
  BVI Bridge-Group Virtual Interface
  CTunnel CTunnel interface
  Dialer Dialer interface
  Ethernet IEEE 802.3
  Group-Async Async Group interface
  Lex Lex interface
  Loopback Loopback interface
  Multilink Multilink-group interface
  Null Null interface
  Serial Serial
  Tunnel Tunnel interface
  Vif PGM Multicast Host interface
  Virtual-Template Virtual Template interface
  Virtual-TokenRing Virtual TokenRing
  range interface range command
  
  以上是我们实验室2501路由器的接口。
  激活接口
  使用shutdown来关闭接口,用no shutdown命令打开一个接口
  下列显示了如何打开一个接口:
  
  Router(config)#int s0
  Router(config-if)#no shut
  在接口上配置IP地址
  即使在路由器上不需要直接使用IP,但是人们还是要经常使用它。
  要在接口上配置IP地址,是用ip address命令:
  Router(config)#int s0

  Router(config-if)#ip address 192.168.0.1 255.255.255.0
  Router(config-if)#no shut
  最后一定要记住使用no shutdown命令来打开接口。
  
  串行接口命令
  接口将被接到一个CSU/DSU类型的设备上,它要为线路提供时钟。假如是用背对背的配置模式,DCE的连接端必须提供式中。默认时,Cisco的路由器都是数据终端设备(DTE)。
  配置DEC串行接口使用clock rate命令:
  Router#config t
  Enter configuration commands, one per line. End with CNTL/Z.
  Router(config)#int s0
  Router(config-if)#clock rate 64000
  主机名
  使用hostname命令来设置路由器的标识。它只在局部有作用,并不影响路由器的名称查找或路由器在互联网上的工作。
  举例:
  Router(config)#hostname SZ_Lab
  SZ_Lab(config)#hostname Cisco
  Cisco(config)#
  
  描述
  在接口上设置描述非常有意义,以免忘记了哪个接口是连接到哪里的这些。
  和主机名一样,它是只在本地有意思的设置。
  Cisco(config)#int s0
  Cisco(config-if)#description WAN to school
  以下是show run信息
  !
  interface Serial0
  description WAN to school
  ip address 192.168.0.1 255.255.255.0
  !
  查看并保存配置
  使用copy running-config startup-config命令,将配置从DRAM中手工保存到NVRAM中。
  Cisco#copy run start
  Destination filename [startup-config] [ENTER]
  Building configuration...
  [OK]
  
  要删除启动配置文件,使用erase startup-config命令
  Cisco#erase startup-config
  Erasing the nvram filesystem will remove all configuration files! Continue [confirm][ENTER]
  [OK]
  Erase of nvram: complete
  Cisco#reload(从启路由器命令)
  
  验证配置
  show interface命令
  sh ip interface命令
  sh ip interface brief命令
  sh controllers命令。
  
  第五章, IP路由
  
  本章中讲学习如何配置并验证Cisco路由器上的IP路由。
  内容包括:
  1. 静态路由
  2. 默认路由
  3. 静态路由
  
  路由基础
  要完成对数据包的路由,一个路由器必须至少了解以下内容:
  1. 目的地址
  2. 项链路由器,并可以从哪里获得远程网络的信息
  3. 到所有远程网络的可能路由
  4. 到达每个远程网络的最佳路由
  5. 如何维护并验证路由信息
  
  在网络上配置IP路由
  不同路由类型是
  1. 静态路由
  2. 默认路由
  3. 动态路由
  静态路由
  用手工的方式将路由添加到每台路由器的路由表中去,这种方式就是静态路由。
  静态路由有优点,也有缺点。
  
  有以下优点:
  1. 对于路由器的CPU没有治理性开销。
  2. 在路由器之间没有带宽占用。
  3. 他增加了安全性,因为治理员可以有选择地答应路由之访问特定的网络。
  
  有以下缺点:
  1. 治理员必须真正的了解所配置的互联网络,以及每台路由器应该如何正确的连接以正确配置这些路由。
  2. 假如某个网络加入到互联的网络中,治理员必须在所有的路由器上通过人工添加对它的路由。
  3. 对于大型网络,这几乎不可行,因为静态路由会导致巨大的工作量。
  添加静态路由到路由表的语法如下:
  Ip route [destination_network] [mask] [next-hop_address] [administrative_distance] [permanent]
  
  命令中每个字段的描述:
  1. Ip route 用于创建静态路由的命令。
  2. Destination_network 在路由表中要防止的网络号。
  3. Mask 在这一网络上使用的子网掩码。
  4. Next-hop_address 下一跳路由器的地址。
  5. administrative_distance 默认时,静态路由有一个取值为1的治理性距离。在这个命令的尾部添加治理权来修改这个默认值。
  6. Permanent 假如这个接口被关闭或路由器不能与下一跳路由器进行通信,这一路由将会自动从路由表中删除。
  
  静态路由举例:
  配置Lab_A静态路由:
  Lab_A了解自己的网络192.168.10.0和192.168.20.0(直接相连),所以RouterA的路由表必须加入192.168.30.0和192.168.40.0, 192.168.50.0的信息,注重下1跳接口,如下:
  Lab_A(config)#ip route 192.168.30.0 255.255.255.0 192.168.20.2
  Lab_A(config)#ip route 192.168.40.0 255.255.255.0 192.168.20.2
  Lab_A(config)#ip route 192.168.50.0 255.255.255.0 192.168.20.2
  
  配置Lab_B静态路由:
  配置如下:
  Lab_B(config)#ip route 192.168.10.0 255.255.255.0 192.168.20.1
  Lab_B(config)#ip route 192.168.50.0 255.255.255.0 192.168.40.2

  
  配置RouterC静态路由:
  配置如下:
  Lab_C(config)#ip route 192.168.10.0 255.255.255.0 192.168.40.1
  Lab_C(config)#ip route 192.168.20.0 255.255.255.0 192.168.40.1
  Lab_C(config)#ip route 192.168.30.0 255.255.255.0 192.168.40.1
  
  默认路由
  使用默认路由可以转发那些在路由表中没有列出的远端目的网络的数据包到下一跳路由器。
  举例:
  Cisco(config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1
  意思是,路由表里面没有的路由条目,就直接扔给下一跳IP192.168.40.1这个路由器。假如不能到达目的网络,那么直接把包扔掉。
  
  动态路由
  使用协议来查找并更新路由表的配置,就是动态路由。
  动态路由举例:
  
  Lab_a(config-if)#int s 0/0
  Lab_a(config-if)#ip address 192.168.20.1 255.255.255.0
  Lab_a(config-if)#no shut
  Lab_a(config-if)#^Z
  Lab_a#copy run start
  
  Lab_b(config-if)#int s 0/0
  Lab_b(config-if)#ip address 192.168.20.2 255.255.255.0
  Lab_b(config-if)#clock rate 64000
  Lab_b(config-if)#no shut
  Lab_b(config-if)#ip address 192.168.40.1 255.255.255.0
  Lab_b(config-if)#clock rate 64000
  Lab_b(config-if)#no shut
  Lab_b(config-if)#^Z
  Lab_b#copy run start
  
  Lab_c(config-if)#int s 0/0
  Lab_c(config-if)#ip address 192.168.40.2 255.255.255.0
  Lab_c(config-if)#no shut
  Lab_c(config-if)#^Z
  Lab_c#copy run start
  
  路由选择协议基础
  治理距离
  治理距离(AD)是用来衡量接收来自相邻路由器上路由选择信息的可信度的。
  默认的治理距离
  路由源 默认AD
  连接接口 0
  静态路由 1
  EIGRP 90
  IGRP 100
  OSPF 110
  RIP 120
  Externat EIGRP 170
  未知 255(这个路由将绝不会被使用)
  
  路由选择协议
  1. 距离矢量
  2. 链路状态
  3. 混合型
  距离矢量路由选择协议
  某个网络可能会有多个链路可以到达统一个远程网络。假如这一情况出现,治理举例首先将被检查。假如AD是相同的,协议将会使用其他量度值来决定到达远程网络的最佳路径。
  
  路由环路
  距离矢量路由选择协议会通过定期的广播路由更新所有激活的接口,来跟踪互联网络中的任何变化。
  路由环路的发生是由于每台路由器不能同时或接近同时的完成路由表的更新。
  
  最大跳计数
  由于环路的问题可以简单的描述为无穷大计数,它是由于通告互联网络通信和传播的传言及错误的信息所造成的。
  
  水平分割
  另一个解决路由环路问题的方案被称为水平分割。
  
  路由毒杀
  另一个避免有不一致更新造成的问题并组织网络环路产生的方法是路由毒杀。
  
  保持关闭
  保持关闭可以组织定期的更新消息去恢复一个不断开闭的路由。
  当出发更新重新设置保持关闭定时器时,会有三种情况发生:
  1. 保持关闭定时器期满
  2. 另一个带有更好的度量更新被接收到
  3. 刷新定时,即一个路由在被删除之前,从路由表中删除该路由需要保持的时间。
  
  路由信息协议(RIP)
  RIP是一个真正的距离矢量路由选择协议。它每隔30秒钟就送出自己完整的路由表到所有激活的接口。RIP只使用跳计数来决定到达远程网络的最佳方式,并且在默认时它所答应的最大跳计数为15条,16跳的距离将被认为是不可达的。
  
  RIP定时器
  1. 路由更新定时器
  2. 路由失效定时器
  3. 保持失效定时器
  4. 路由刷新定时器
  
  配置RIP路由
  Lab_A(config)#router rip
  Lab_A(config-router)#network 192.168.10.0
  Lab_A(config-router)#network 192.168.20.0
  Lab_A(config-router)#^Z
  Lab_A#
  
  Lab_B(config)#router rip
  Lab_B(config-router)#network 192.168.20.0
  Lab_B(config-router)#network 192.168.30.0
  Lab_B(config-router)#network 192.168.40.0
  Lab_B(config-router)#^Z
  Lab_B#
  
  Lab_C(config)#router rip
  Lab_C(config-router)#network 192.168.50.0
  Lab_C(config-router)#network 192.168.40.0
  Lab_C(config-router)#^Z
  Lab_C#
  
  内部网关路由协议(IGRP)
  内部网管协议是一个Cisco专用的距离矢量路由选择协议。要使用igrp的话,所用的路由器必须是Cisco的路由器。
  IGRP的最大跳计数值为255,默认时为100。
  
  RIP所不具备的IGRP特性:
  1. IGRP可以被用于大型网络
  2. IGRP使用自治系统号

  3. IGRP每90秒发送一次全路由表更新
  4. IGRP使用宽带和线路延迟做为度量(最低的合成度量)
  
  IGRP定时器
  1. 更新定时器
  2. 失效定时器
  3. 保持关闭定时器
  4. 刷新定时器
  
  配置EIGRP路由
  Lab_A(config)#router igrp
  <1-65535> Autonomous system number
  Lab_A(config)#router igrp 100
  Lab_A(config-router)#netw 192.168.10.0
  Lab_A(config-router)#netw 192.168.20.0
  Lab_A(config-router)#^Z
  Lab_A#
  
  Lab_B(config)#router igrp 100
  Lab_B(config-router)#netw 192.168.20.0
  Lab_B(config-router)#netw 192.168.30.0
  Lab_B(config-router)#netw 192.168.40.0
  Lab_B(config-router)#^Z
  Lab_B#
  
  Lab_C(config)#router igrp 100
  Lab_C(config-router)#netw 192.168.40.0
  Lab_C(config-router)#netw 192.168.50.0
  Lab_C(config-router)#^Z
  Lab_C#
  
  第六章, 增强IGRP(EIGRP)和开放最短路径优先(OSPF)
  
  增强内部网管路由协议是一个Cisco的专用协议,它可以运行在Cisco路由器上,也可以运行在位于Cisco分层和核心层上的内部路由处理器上。
  EIGRP的特点和操作
  EIGRP是一个无类、增强的距离矢量协议,同内部网管路由选择协议一样,它是又一个Cisco专用协议,并且应用范围是在IGRP之上。
  有时EIGRP也被称为是混合型路由选择协议,因为它同时拥有距离矢量和链路状态两种协议的特性。
  
  EIGRP主要功能的部分内容:
  1. 通过协议相关模块支持IP、IPX和AppleTalk
  2. 有效的邻居发现
  3. 给予可靠传输协议(RTP)的通信
  4. 给予弥散更新算法(DUAL)的最佳路径选择
  
  协议相关模块
  EIGRP它为多种网络曾协议提供路由支持。
  EIGRP通过使用协议相关模块(PDM)支持不同的网络层协议。
  
  邻居发现
  在EIGRP路由器彼此交换路由之前,他们必须是邻居。建立邻居关系必须要满足三个条件:
  1. 收到hello包或ACK
  2. 匹配的AS号
  3. 相同的度量(K值)
  
  EIGRP术语:
  可行的距离 这是一个眼所有路径到达远程网络的最佳度量,并且包含有正在与该远程网络通告的邻居的度量。
  被报告距离 这是一个由邻居报告的到达远程网络的度量。
  可行的继任者 可行的继任者是一条路径,它所报告的距离要比可行距离差一些,并且他被认为是一条备份路由。
  
  可靠传输协议
  EIGRP使用专用的协议来治理EIGRP发话者路由器间的消息通信。
  
  弥散更新算法
  EIGRP为选择并维持到达每个远程网络的最佳路径,使用弥散更新算法(DUAL)。
  这个算法可以做到:
  1. 假如可用则备份路由
  2. 支持可变长子网掩码(VLSM)
  3. 动态的路由恢复
  4. 假如没有路由被发现则发送替换路由查询
  使用EIGRP来支持大型网络
  EIGRP包含了许许多多的强大功能:
  在单个路由器上支持多个AS
  支持VLSM和汇总
  路由发现和维护
  多个AS
  EIGRP使用自制系统号来区别可共享路由信息的路由器集合。路由信息之可以在拥有相同自治系统号的路由器间共享。在大型网络中,你可以轻易地终结那些在分散的计算操作中因复杂拓扑和路由表而导致的慢汇聚。
  VLSM支持和汇总
  EIGRP支持使用变长子网掩码。
  EIGRP也支持在任一或全部EIGRP路由器上创建汇总,汇总可以尽可能地缩减路由表的尺寸。
  在默认时,这是绝不会工作的!注重到,默认时,RIP、RIPv2和IGRP也可以在这些边界上执行自动汇总,但OSPF则不能。
  路由发现和维持
  和许多链路状态协议一样,EIGRP支持邻居的概念,这些邻居是通过Hello过程来发现的,并且邻居状态是要受监视的。
  
  EIGRP使用一系列的标来保存这些关于环境的重要信息:
  1. 邻居关系表
  2. 拓扑表
  3. 路由表
  邻居关系表记录着有关路由器与已建立起来的邻居关系的信息。
  拓扑表保存这在互连网中每个路由器从每个邻居处接收到的路由通告。
  路由表保存这当前使用者的用于路由判定的路由。
  
  EIGRP的度量
  EIGRP的另一个受欢迎的特点是没它使用了一个单一量度来比较并选择最佳的可用路径,EIGRP的度量时四个要素的组合:
  1. 带宽
  2. 延迟
  3. 负载
  4. 可靠性
  同IGRP一样,默认时,EIGRP只使用带宽和线路的延迟来判定到达远程网络的最佳路径。
  
  配置EIGRP
  根据EIGRP命令的输入不同又两种模式:路由器配置模式和借口配置模式。
  路由器配置模式启用该协议,判定那个网络将要运行EIGRP,并且设置全局参数。
  接口配置模式答应定制汇总、度量、定时器和宽带。
  要在一台路由器上开始EIGRP会话,使用router eigrp命令,并在其后制定你网络的自治系统号。然后使用带有网络的network命令,输入连接到路由器上的网络号。
  Lab_A(config)#router eigrp 50
  Lab_A(config-router)#netw 192.168.20.0
  
  Lab_B(config)#router eigrp 50
  Lab_B(config-router)#netw 192.168.20.0
  Lab_B(config-router)#netw 192.168.40.0
  
  Lab_C(config)#router eigrp 50

  Lab_C(config-router)#netw 192.168.40.0
  
  开放最短路径优先(OSPF)基础
  OSPF是一个开放标准的路有选择协议,他被各种网络开发商所广泛使用,其中包括Cisco。
  OSPF是通过使用Dijkstra算法来工作的。首先,要构建一个最短路径树,然后使用最佳路径的计算结果来组建路由表。OSPF汇聚很快,虽然他可能没有EIGRP快,并且它也支持到达相同目标的多个等开销路由。但是与EIGRP不同,它只支持IP路由选择。
  OSPF和RIPv1比较
  特性 OSPF RIPv1
  协议类型 链路状态 距离矢量
  无类支持 是 否
  VLSM支持 是 否
  自动归类 否 是
  手动归类 是 否
  路由传播 可变化的组波 周期性广播
  路径度量 宽带 跳
  跳计数限制 无 15
  汇聚 快 慢
  对等认证 是 否
  分层网络 是(使用区域) 否(只对平面)
  路由计算 Dijkstra Bellman-Ford
  
  OSPF术语
  1. 链路
  2. 路由器ID
  3. 邻居
  4. 邻接
  5. 邻居关系数据库
  6. 拓扑数据库
  7. 链路状态通告
  8. 指定路由器
  9. 备用指定路由器
  10. OSPF区域
  11. 广播(多路访问)
  12. 非广播的多路访问
  13. 点到点
  14. 点到多点
  SPF树的计算
  在区域内部,每个路由器都计算到达统一区域中每个网络的最佳/最短路径。
  
  配置OSPF
  OSPF配置中的基本元素:
  1. 启动OSPF
  2. 配置OSPF区域
  
  启动OSPF
  配置OSPF最简单也是最低级的方式就是使用单一区域。
  用于激活OSPF路由进程的命令是:
  Lab_A(config)#router ospf
  <1-65535> Process ID
  OSPF 使用一个取值于范围1-65535内的数来识别进程的ID。
  
  配置OSPF区域
  在标识了OSPF的进程后,接下来需要标识想要进行OSPF通信的接口,及路由器所在的区域。
  OSPF在配置中使用了通配符掩码,该掩码也被应用在访问控制列表的配置中。
  
  配置ospf基本实例:
  Lab_A(config)#router ospf 1
  Lab_A(config-router)#netw 192.168.20.0 0.255.255.255 area 0
  Lab_A(config-router)#
  
  Lab_B(config)#router ospf 1
  Lab_B(config-router)#netw 192.168.40.0 0.0.0.255 area 0
  Lab_B(config-router)#netw 192.168.20.0 0.0.0.255 area 0
  Lab_B(config-router)#
  
  Lab_C(config)#router ospf 1
  Lab_C(config-router)#netw 192.168.40.0 0.0.0.255 area 1
  Lab_C(config-router)#
  
  第八章, 虚拟局域网(VLAN)
  
  在一个纯交换式的互联网络中,通过创建虚拟局域网(VLAN)就可以分隔广播域。
  VLAN是两个部分各逻辑组合:一是网络用户;二是治理上连接到交换机所定义端口的资源。
  默认时,在一个VLAN中的所有主机都不能与另外一个VLAN中的任何主机进行通信,因此,假如想要在VLAN之间通信,那就还需要路由器。
  
  用VLAN来简化网络治理的方式有多种:
  1. 通过将某个端口配置到合适的VLAN中,就可以实现网络的添加、移动和改变。
  2. 将对安全性要求高的一组用户放入VLAN中,这样,VLAN外部的用户就无法与他们通信。
  3. 作为功能上的逻辑用户组,可以认为VLAN独立于他们的无理位置或地理位置。
  4. VLAN可以增强网络安全性。
  5. VLAN增加了广播域的数量,减小了广播域的范围。
  
  广播控制
  每种协议都回产生广播,但他们产生广播的频度取决于下面3项:
  1. 协议的类型
  2. 运行在互联网络上的应用程序
  3. 怎样使用这些服务
  
  安全性
  平面网络的安全性问题通常是通过将集线器和交换机一起连接到路由器上来解决,因此,路由器的基本工作就是维护安全性。
  由于连接到无理网络的任何人都可以访问位于物理LAN上的网络资源。只要简单的往集线器中插入一个网络分析器,任何人都可以观察到在网络上的任何通信流。用户只需将其工作站插入到现有集线器中,就可以加入某个工作组。因此,根本没有安全性可言。
  
  灵活性和可扩展性
  第二层交换机在过滤时只读取帧,他们并不察看网络层的协议,而默认时交换机转发所有的广播。假如创建并实现了VLAN,本质上就可以在第二层创建更小的广播域。
  在一个VLAN上的节点所发送的广播,将不会被转发到配置在其他VLAN中的端口。
  
  VLAN成员关系
  VLAN通常是由治理员创建的,并由治理员将交换机端口分配到每个VLAN中,这种类型的VLAN称为静态VLAN。将主机设备的硬件地址都分配到一个数据库中,那么,无论什么时候主机插入到交换机中,交换机都可以配置为动态地分配VLAN,这种方式称为动态VLAN。
  
  静态VLAN(Static VLAN)
  在创建VLAN时,通常都是创建静态VLAN,静态VLAN也是最安全的。
  

  动态VLAN(Dynamic VLAN)
  动态VLAN能够自动决定一个节点的VLAN分配。通过使用智能化的治理软件,就可以启用MAC地址、协议甚至应用程序来创建动态VLAN。
  
  VLAN的识别
  当帧通过互联网络进行交换时,交换机必须能够跟踪所有不同类型的帧,而且还要知道怎样对他们进行操作,这取决于硬件地址。根据帧所穿越的链路类型的不同,对帧的处理方式也不同。
  
  在交换式网络中,有两种不同类型的链路:
  访问链路: 这种类型的链路只是某个VLAN的一部份,它被称为端口的本机访问。
  中继链路: 中继线可以承载多个VLAN。
  
  帧标志
  可以将VLAN创建为跨越多台连接在一起的交换机。
  
  VLAN的识别方法
  VLAN的识别是指当帧正在穿越交换机结构时,交换机跟踪所有这些帧的方式,它指的是交换机怎样识别哪一个帧属于哪一个VLAN。
  交换机间链路 在交换机端口、路由器接口和服务器接口卡上,可以使用ISL路由来中继到服务器。
  IEEE 820.1Q 它是由IEEE创建的,作为帧标志的标准方法,它实际上是在帧中插入一个字段,以标识VLAN。
  
  交换机间链路(Inter-Switch Link, ISL)协议
  这是一种以太网帧上显示地标志VLAN信息的方法。
  通过运行ISL,可以将多台交换机互联起来,并且当数据流在交换机之间的中继链路上传送时,仍然维持VLAN信息。
  
  VLAN中继协议(VLAN Trunk Protocol,VTP)
  VTP的基本目标是,跨交换是互联网络治理所有已经配置好的VLAN,并在那个网络上维护其一致性。
  VTP提供的一些好处:
  1. 在网络中所有的交换机上实现VLAN配置的一致性。
  2. 答应VLAN在混合式网络上进行中继
  3. VLAN的精确跟踪和监控
  4. 将所添加的VLAN动态地报告给VTP域中的所有交换机
  5. 添加VLAN时即插即用
  
  VTP的操作模式
  有三种不同的操作模式:
  1. 服务器(Server) 在VTP域中,至少需要一台服务器,以便在整个域中传播VLAN信息。
  2. 客户机(Client) 在客户机模式下,交换机从VTP服务器接收信息,他们也发送和接收更新,但他们不做任何改动。
  3. 透明(Transparent) 在透明模式下,交换机不参与VTP域,但他们仍然将通过任何已经配置好的中继链路转发VTP通告。
  
  VTP修剪
  VTP提供了一种方式来保留带宽,就是通过配置它来减小广播、组播和其他单播包的数量,这种方式就成为修剪。
  VLAN之间的路由
  VLAN中的主机处在自己的广播域内,并且可以自由通信。VLAN在OSI模型的第二层创建网络分段,并分割数据流。假如想让主机或任何其他IP设备在VLAN之间通信,就绝对需要第三层设备。
  
  配置VLAN
  创建VLAN:
  1900下,使用vlan [vlan#] name [name] [vlan#]命令, 如下:
  >en
  #config t
  (config)#hostname 1900
  1900(config)#vlan 2 name sales
  1900(config)#vlan 3 name marketing
  1900(config)#vlan 4 name mis
  1900(config)#exit
  验证,使用show vlan命令,记住在你没给VLAN分配端口之前,之前做的VLAN是不会起作用的.而且所有的端口默认是处在VLAN1的,VLAN1是治理VLAN.如下:
  1900#sh vlan
  VLAN Name Status Ports
  ----------------------------------------------------------------------------
  1 default Enable 1-12, AUI, A, B
  2 sales Enable
  3 marketing Enable
  (略)
  在2950下创建VLAN,在特权模式下使用vlan database命令,创建命令和1900下的类似,注重结尾使用apply命令.如下:
  2950#vlan database
  2950(vlan)#vlan 2 name Marketing
  VLAN 2 modified:
  Name: Marketing
  2950(vlan)#vlan 3 name Accounting
  VLAN 3 added:
  Name: Accounting
  2950(vlan)#apply
  APPLY complete
  2950(vlan)#Ctrl+C
  2950#
  使用show vlan或者show vlan brief命令验证下:
  2950#sh vlan brief
  VLAN Name Status Ports
  ----------------------------------------------------------------------------
  1 default active Fa0/1...Fa0/12
  2 Marketing active
  3 Accounting active
  (略)
  
  将交换机端口分配到VLAN中
  创建了VLAN,接下来要做的就是给VLAN分配端口.1900下,使用vlan-membership命令1次只能分配1个,可以static或dynamic作为参数,如下:
  1900(config)#int e0/2
  1900(config-if)#vlan-membership static 2
  1900(config)#int e0/4
  1900(config-if)#vlan-membership static 3
  1900(config)#int e0/5
  1900(config-if)#vlan-membership static 4
  1900(config-if)#exit
  1900(config)#exit
  1900#
  验证,如下:
  1900#sh vlan
  VLAN Name Status Ports
  ----------------------------------------------------------------------------

  1 default Enable 1-12, AUI, A, B
  2 sales Enable 2
  3 marketing Enable 4
  (略)
  2950下的配置,使用switchport access vlan [vlan#]命令,如下:
  2950(config-if)#int f0/2
  2950(config-if)#switchport access vlan 2
  2950(config-if)#int f0/3
  2950(config-if)#switchport access vlan 3
  2950(config-if)#int f0/4
  2950(config-if)#switchport access vlan 4
  2950(config-if)#exit
  2950(config)#exit
  2950#
  验证配置信息,如下:
  2950#sh vlan brief
  VLAN Name Status Ports
  ----------------------------------------------------------------------------
  1 default active Fa0/1 Fa0/5...Fa0/12
  2 Marketing active Fa0/2
  3 Accounting active Fa0/3
  (略)
  
  配置中继端口
  
  1900只使用动态ISL(DISL)封装方式,在快速以太网配置trunk,在接口配置模式下使用trunk [参数]的命令,如下,将26接口设置为trunk端口:
  1900(config)#int f0/26
  1900(config-if)#trunk
  auto Set DISL state to AUTO
  desirable Set DISL state to DESIRABLE
  nonegotiate Set DISL state to NONEGOTIATE
  off Set DISL state to OFF
  on Set DISL state to ON
  1900(config-if)#trunk on
  设置参数为on即接口将作为永久ISL的trunk端口,可以和和相连的设备协商,并且把连接转换成trunk link
  2950下在接口配置模式,使用switchport命令,如下:
  2950(config)#int f0/12
  2950(config-if)#switchport mode trunk
  2950(config-if)#^Z
  2950#
  验证配置信息:
  2950#sh run
  (略)
  !
  interface FastEthernet0/12
  switchport mode trunk
  no ip address
  !
  
  配置VLAN之间的路由
  默认时,只是在同一个VLAN中的主机才能彼此通信。要实现VLAN之间的通信,就需要路由器或第三层交换机。
  要在FastEthernet端口上支持ISL或802.1Q路由,路由器的接口就需要分成逻辑上的接口,每个VLAN都需要一个逻辑接口。这些接口称为子接口。
  默认时不能在1900交换机和2950交换机之间提供中继,理解这一点是很重要的,因为1900交换机只支持ISL路由,而2950交换机只支持820.1Q路由,默认时这两种中继方法是不兼容的。
  对于到1900 trunk端口(ISL)的连接,可使用如下命令:
  2600#config t
  2600(config)#int f0/0.1
  2600(config-subif)#encapsulation isl vlan#
  要实现到2950交换机(802.1Q)的路由器中继连接,可使用下列命令:
  2600(config)#int f0/0.1
  2600(config-subif)#encapsulation dot1q vlan#
  要理解每个VLAN都是独立的子网,这一颠很重要。
  
  配置VTP
  所有的交换机,在默认时都配置为VTP服务器。要配置VTP,首先必须配置你想要使用的VTP域名。
  在创建VTP域时,有一些选项,包括设置域名、口令、操作模式和交换机的修建功能。可使用VTP全局配置模式命令来设置所有这些信息。在下面的列兹中,我将交换机设置为VTP server,将VTP域名设置为Cisco,将VTP口令设置为12345:
  1900(config)#vtp server
  1900(config)#vtp domain Cisco
  1900(config)#vtp password 12345
  默认时所有的交换机都设置为VTP服务器模式,假如想在交换机上改动任何有关VLAN的信息,都必须在VTP服务器模式下进行。
  在2950交换机上配置VTP,同样要首先配置想要使用的域名。同样,一旦在交换机上配置了VTP信息,就需要验证它。可使用VTP全局配置模式命令来设置这些信息。
  例子中,把交换机设置为服务器模式,域名设置为SZ_Lab
  Switch(config)#vtp mode server
  Switch(config)#vtp domain SZ_Lab
  
  配置示例互联网络中的交换
  先配置2950C,如下
  2950C(config)#enable secret noko
  2950C(config)#line con 0
  2950C(config-line)#login
  2950C(config-line)#password noco
  2950C(config-line)#line vty 0 15
  2950C(config-line)#login
  2950C(config-line)#password noco
  2950C(config-line)#banner motd #
  2950C
  #
  2950C(config-line)#exit
  2950C(config)#int vlan1
  2950C(config-if)#ip address 172.16.10.2 255.255.255.0
  2950C(config-if)#no shut
  2950C(config-if)#exit

  2950C(config)#up default-gateway 172.16.10.1
  2950C(config)#^Z
  2950C#copy run start
  配置2950B,如下:
  2950B(config)#enable secret noko
  2950B(config)#line con 0
  2950B(config-line)#login
  2950B(config-line)#password noco
  2950B(config-line)#line vty 0 15
  2950B(config-line)#login
  2950B(config-line)#password noco
  2950B(config-line)#banner motd #
  2950B
  #
  2950B(config-line)#exit
  2950B(config)#int vlan1
  2950B(config-if)#ip address 172.16.10.3 255.255.255.0
  2950B(config-if)#no shut
  2950B(config-if)#exit
  2950B(config)#up default-gateway 172.16.10.1
  2950B(config)#^Z
  2950B#copy run start
  配置trunk,2950B如下:
  2950B(config)#int f0/1
  2950B(config-if)#switchport mode trunk
  2950B(config-if)#int f0/4
  2950B(config-if)#switchport mode trunk
  2950B(config-if)#int f0/5
  2950B(confgi-if)#switchport mode trunk
  配置trunk,2950C如下:
  2950C(config)#int f0/4
  2950C(confgi-if)#switchport mode trunk
  2950C(config-if)#int f0/5
  2950C(config-if)#switchport mode trunk
  验证trunk信息,使用show interface trunk命令.如下:
  2950B#sh int trunk
  Port Mode Encapsulation Status Native vlan
  Fa0/1 on 802.1q trunking 1
  Fa0/4 on 802.1q trunking 1
  Fa0/5 on 802.1q trunking 1
  (略)
  之前我们已经对2950B和2950C做了基本配置和trunk端口的配置,接下来应该设置VTP和创建VLAN,并且进行验证.2950C如下:
  2950C(config)#vtp mode server
  2950C(config)#vtp domain Cisco
  2950C(config)#^Z
  2950C#vlan database
  2950C(vlan)#vlan 2 name sales
  2950C(vlan)#vlan 3 name marketing
  2950C(vlan)#apply
  2950C(vlan)#^C
  2950C#sh vlan brief
  (略)
  接下来分配端口,把Fa0/2分配给VLAN2,Fa0/3分配给VLAN3,默认所有的端口都处在VLAN1下,配置如下:
  2950C(config)#int fa0/2
  2950C(config-if)#switchport access vlan2
  2950C(config)#int fa0/3
  2950C(config-if)#switchport access vlan3
  验证信息,注重VLAN1里的Ports栏,如下:
  2950C#sh vlan brief
  VLAN Name Status Ports
  ----------------------------------------------------------------------------
  1 default active Fa0/1 Fa0/5...Fa0/10
  2 sales active Fa0/2
  3 marketing active Fa0/3
  配置2950B,把它设置成客户模式,2950B从2950C接收VLAN信息,如下:
  2950B(config)#vtp mode client
  2950B(config)#vtp domain Cisco
  2950B(config)#^Z
  验证,注重2950B已经从2950C知道了VLAN的信息,如下:
  2950B#sh vlan brief
  VLAN Name Status Ports
  ----------------------------------------------------------------------------
  1 default active Fa0/1...Fa0/12
  2 sales active
  3 marketing active
  但是仍然要给2950B分配端口,如下:
  2950B(config)#int fa0/2
  2950B(config-if)#switchport access vlan2
  2950B(config)#int fa0/3
  2950B(config-if)#switchport access vlan3
  验证信息,如下:
  VLAN Name Status Ports
  ----------------------------------------------------------------------------
  1 default active Fa0/1 Fa0/5...Fa0/12
  2 sales active Fa0/2
  3 marketing active Fa0/3
  到现在,2950C和2950B的配置就算是完成了,经过验证,我们也没发现什么问题,接下来该配置什么呢当然是配置VLAN间的通信,根据上面的拓扑图,可以知道需要在RouterB上进行配置,如下:

  RouterB(config)#hostname Trunkrouter
  Trunkrouter(config)#int f0/0
  Trunkrouter(config-if)#no ip address
  Trunkrouter(config-if)#no shut
  创建子接口,并定义封装类型,如下:
  Trunkrouter(config-if)#int f0/0.1
  Trunkrouter(config-subif)#encapsulation dot1q 1
  Trunkrouter(config-subif)#ip address 172.16.10.1 255.255.255.0
  Trunkrouter(config-if)#int f0/0.2
  Trunkrouter(config-subif)#encapsulation dot1q 2
  Trunkrouter(config-subif)#ip address 172.16.20.1 255.255.255.0
  Trunkrouter(config-if)#int f0/0.3
  Trunkrouter(config-subif)#encapsulation dot1q 3
  Trunkrouter(config-subif)#ip address 172.16.30.1 255.255.255.0
  Trunkrouter(config-if)#exit
  创建子接口,每个接口对应1个VLAN.注重,假如你试图在第一个子接口分配IP地址,将收到错误信息,除非你先定义了封装类型,如下:
  Trunkrouter(config-if)#int f0/0.1
  Trunkrouter(config-subif)#ip address 172.16.10.1 255.255.255.0
  Configuring IP routing on a LAN subinterface is only allowed if that subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q, or ISL VLAN.
  
  第九章, 治理Cisco互联网络
  
  本章学习重点:
  1. 备份和恢复Cisco IOS
  2. 备份和恢复Cisco配置
  3. 通过CDP和Telnet收集相邻设备的相关信息
  4. 解析主机名
  5. 使用ping和traceroute命令测试网络连接
  
  Cisco路由器的内部组件
  1. bootstrap
  2. post
  3. ROM
  4. 小型IOS
  5. RAM
  6. ROM
  7. NVRAM
  8. Configuration register
  
  路由器启动顺序
  启动顺序包括下列步骤
  1. 路由器执行POST。
  2. Bootstrap查找并加载Cisco IOS软件。
  3. IOS软件在NVRAM中查找有效的配置文件。
  4. 假如NVRAM中有startup-config文件,路由器将加载并运行此文件。
  
  治理配置寄存器
  所有Cisco路由器都具有一个位于NVRAM中的16位软件寄存器。默认情况下,配置寄存器设置为从闪存加载startup-config文件。
  
  理解配置寄存器位
  配置寄存器的16位从左到右是从15读到0。Cisco路由器默认的配置设置时0x2102。
  
  软件配置意义
  位 十六进制 解释
  0-3 0x0000-0x000f 启动字段
  6 0x0040 忽略NVRAM内容
  7 0x0080 启用OEM位
  8 0x101 禁用中断
  10 0x0400 IP广播全为零
  5、11-12 0x0800-0x1000 控制台线路速率
  13 0x2000 假如网络启动实效则启动默认ROM软件
  14 0x4000 IP广播包含网络号
  15 0x8000 启用诊断信息并忽略NVRAM内容
  位于配置寄存器0位-3位的启动字段控制路由器的启动顺序。
  检查当前配置寄存器值
  使用show version命令可以查看配置寄存器的当前值。
  Cisco Internetwork Operating System Software
  IOS (tm) 2500 Software (C2500-JS56I-L), Version 12.1(5)T12, RELEASE SOFTWARE (fc1)
  TAC Support: http://www.cisco.com/tac
  Copyright (c) 1986-2002 by cisco Systems, Inc.
  (略)
  Configuration register is 0x2142
  命令最后给出的信息就是配置寄存器的值。
  修改配置寄存器的值
  可以通过修改配置寄存器的值来修改路由器如何启动和运行。
  
  下面是修改配置寄存器的可能原因:
  1. 强制系统进入ROM监控模式
  2. 选择启动来源和默认的启动文件名
  3. 启用或禁用Break(中断)功能
  4. 控制广播地址
  5. 设置控制台中断波特率
  6. 从ROM加载操作软件
  7. 启用从TFTP启动服务器
  使用config-register命令修改配置寄存器。
  下面命令告诉路由器忽略NVRAM内容:
  Router(config)#config-register 0x2142
  Router(config)#^Z
  Router#sh ver
  (略)
  Configuration register is 0x2142
  
  恢复口令
  假如忘记了口令,可以通过修改寄存器的值来进行恢复。
  默认的配置寄存器值是0x2102,在默认情况下,路由器会查找并加载存储在NVRAM中的路由器配置。现在我们要更改值,让路由器忽略NVRAM的内容。
  这里是口令恢复的主要步骤:
  1. 启动路由器并通过执行一个中断来中断启动顺序
  2. 修改配置寄存器开启第6位(值为0x2142)
  3. 重载路由器
  4. 进入特权模式。
  5. 将startup-config文件复制为running-config文件

  6. 修改口令
  7. 将配置寄存器重设为默认值
  8. 保存路由器的配置
  9. 重载路由器。
  
  下面是具体步骤:
  中断路由器启动顺序
  做法是,当路由器第一次启动时同时按下CTRL+BREAK组和键来执行一个中断。
  修改配置寄存器
  2600系列命令
  Rommon 1> confreg 0x2142
  2500系列命令
  >o/r 0x2142
  从载路由器进入特权模式
  再此情况下,需要像下面这样从蛇路由器:
  2600系列上,输入reset
  2500系列上,输入I(初始化)
  查看并修改配置
  将startup-config文件复制到running-config文件
  Copy startup-config running-config
  缩写 copy start run
  但是不能查看secret设置的口令。要修改口令,这样做
  Config t
  Enable secret 12345
  重设配置寄存器并重载路由器
  使用config-register命令将配置寄存器设置回默认值:
  Config t
  Config-register 0x2102
  最后使用Copy run start 命令保存配置并重载路由器。
  
  备份和恢复Cisco IOS
  在省级或恢复Cisco IOS之前,应当将已有文件复制到TFTP主机作为备份,以防止新的影响文件不能正常运行。
  
  在将IOS映像文件备份到网络服务器之前,完成下列操作:
  1. 确定可以访问网络服务器。
  2. 确保网络服务器对于影响文件具有足够的空间。
  3. 验证所需的文件名以及路径。
  
  验证闪存
  当场是在路由器上专心的IOS文件升级Cisco IOS之前,应当验证闪存具有充足的空间来保存新的映像文件。可以使用sh flash命令验证闪存的容量和姚存储到闪存中文件的大小:
  Router#sh flash
  
  System flash Directory:
  File Length Name/status
  1 16082856 c2500-js56i-l.121-5.T12.bin
  [16082920 bytes used, 694296 available, 16777216 total]
  16384K bytes of processor board System flash (Read ONLY)
  
  这里文件名是c2500-js56i-l.121-5.T12.bin。这个文件名称具有平台特性,名称来源如下:
  1. C2500是指平台类型
  2. J指示此文件时一个企业级映像文件
  3. S指示文件包含扩展性能
  4. L指示在需要时可以从闪存中删除此文件,并且此文件时不可压缩文件
  5. T12是版本号
  6. .bin指示Cisco IOS是二进制可执行文件
  
  备份Cisco IOS
  若要将Cisco IOS备份到TFTP服务器,使用copy flash tftp命令
  恢复或升级Cisco路由器IOS
  可以使用copy tftp flash命令将文件从TFTP服务器下载到闪存中。此命令需要TFTP服务器的IP地址以及要下载到闪存中的文件名。
  在开始操作之前,要确保欲放置到闪存中的文件在服务器默认的TFTP目录下。
  
  备份和恢复Cisco配置
  对于路由器配置进行的任何修改存储在running-config文件中。在修改了running-config后没有执行copy run start命令,那么路由器重载或掉电后修改的内容会丢失。
  备份Cisco路由器配置
  要把路由器的配置文件从路由器复制到TFTP服务器,可以使用copy running-config tftp或copy startup-config tftp。其中一个备份当前正在DRAM中运行的路由器配置,一个备份存储在NVRAM中的路由器配置。
  验证当前配置
  可以使用sh running-config命令
  Router>en
  Router#sh run
  Building configuration...
  
  Current configuration : 547 bytes
  !
  version 12.1
  当前信息表明路由器运行的是IOS 12.1版本
  
  验证存储的配置
  下面,应当检查NVRAM中存储的配置。要察看此配置,使用sh start命令:
  Router#sh start
  Using 547 out of 32762 bytes
  !
  version 12.1
  将当前配置复制到NVRAM
  将running-config复制到NVRAM作为备份,可以确信路由器重载时总是重载Running-config文件。
  Router#copy run start
  Destination filename [startup-config] [Enter]
  Building configuration...
  [OK]
  Router#
  将配置复制到TFTP服务器
  使用copy run tftp命令
  恢复Cisco路由器配置
  使用copy tftp run命令
  删除配置
  使用erase startup-config命令
  Router#erase startup-config
  Erasing the nvram filesystem will remove all files! Continue [confirm][Enter]
  [OK]
  Erase of nvram: complete
  Router#
  使用Cisco发现协议
  Cisco发现协议(CDP)是Cisco私有,帮助用来治理员收集本地相连和远程设备的信息.
  获取CDP定时器和保持时间信息
  
  之前提到过CDP的一些介绍,show cdp命令提供2个信息给你:

  1.CDP timer:CDP包传给每个活跃接口的时间间隔,默认是60秒
  2.CDP holdtime:某设备从相邻设备收到的包的保持时间,默认是180秒
  如下:
  Router#sh cdp
  Global CDP information:
  Sending CDP packets every 60 seconds
  Sending a holdtime value of 180 seconds
  Router#
  
  可以修改默认的时间,分别在全局配置模式下使用cdp timer和cdp holdtime命令,如下:
  Router#conf t
  Router(config)#cdp timer 90
  Router(config)#cdp holdtime 240
  在所有接口上关闭CDP,在全局配置模式下使用no cdp run命令;关闭某个接口的CDP使用no cdp enable命令.再次打开分别使用cdp run和ccdp enable命令.如下:
  Router(config)#no cdp run
  Router(config)#int fa0/1
  Router(config-if)#no cdp enable
  
  收集邻居信息
  使用show cdp neighbour可以显示直接相连的设备的信息,如下:
  Router#sh cdp nei
  Capability Codes: R – Router, T – Trans Bridge,
  B – Source Route Bridge, S – Switch, H – Host,
  I – IGMP, r – Repeater
  Device ID Local Intrfce Holdtime Capability Platform Port ID
  1900Switch Eth 0 238 T S 1900 2
  2500B Ser 0 138 R 2500 Ser 0
  Router#
  
  一些选项的解释如下:
  1.Device ID:直接相连的设备的主机名
  2.Local Interface:接收CDP包的接口
  3.Holdtime:某设备从相邻设备收到的包的保持时间,假如过了这个时间仍然没收到新的CDP包,就将被丢弃
  4.Capability:见输出最顶部信息
  5.Platform:Cisco设备的类型
  6.Port ID:相连设备的接受CDP包信息的接口
  要查看更为具体的CDP信息可以使用show cdp neighbor detail或show cdp entry *命令
  收集借口流量信息
  使用show cdp traffic命令显示接口CDP包流量信息,如下:
  Router#sh cdp traffic
  CDP counters:
  Packets output: 13, Input: 8
  Hdr syntax: 0, Chksum error: 0, Encaps failed: 0
  No memory: 0, Invalid packet: 0, Fragmented: 0
  Router#
  收集端口和接口信息
  使用show cdp interface命令显示接口的CDP状态信息
  使用Telnet
  在特权模式下使用telnet [IP地址]的命令进行telnet,如下:
  Router#telnet 172.16.10.2
  Trying 172.16.10.2 … Open
  Password required, but none set
  [Connection to 172.16.10.2 closed by foreign host]
  Router#
  由上面提示可以看出,VTY没有密码配置的话是不答应你telnet的(除非你使用了no login命令,但是安全性几乎为0).所以在telnet前,记得先给目标设备的VTY线路配置密码
  同时Telnet到多个设备
  当你telnet到远程设备的时候,可以在任何情况下使用exit命令来终止连接.但是假如你想保持这个连接,同时又对另外1个设备进行telnet的时候,使用Ctrl+Shift+6,再按下X键,就可以回到本地console,再对另外1设备进行telnet.如下:
  2500#telnet 172.16.10.2
  Trying 172.16.10.2 … Open
  User Access Verification
  Password:
  2600>[Ctrl+Shift+6,X]
  2500#telnet 192.168.0.32
  (略)
  检查Telnet连接
  查看从本地到远程的连接会话,使用show sessions命令,如下:
  2500#sh sessions
  Conn Host Address Byte Idle Conn Name
  1 172.16.10.2 172.16.10.2 0 0 172.16.10.2
  *2 192.168.0.32 192.168.0.32 0 0 192.168.0.32
  2500#
  注重*所在的会话代表你的最后1个会话,可以直接敲2下Enter键回到*号会话,也可以输入前面的数字,再敲2下Enter键回到相应会话
  检查Telnet用户
  使用show users命令列举本地所有活动console和VTY端口,如下:
  2500#sh users
  Line User Host(s) Idle Location
  * 0 con 0 172.16.10.2 00:07:52
  192.168.0.32 00:07:18
  注重上面输出的con代表本地console,这个例子可以看到从本地console连接了远程的2个设备.接下来在我们远程设备上使用这个命令,如下:
  2600>sh users
  Line User Host(s) Idle Location
  0 con 0 idle 9
  *2 vty 0
  这个输出内容可以看出console是活动的,而且VTY端口2被使用
  关闭Telnet会话
  之前说过,要终止telnet会话,在远程(被telnet)设备上使用exit命令.但是要从本地设备终止会话的话,就需要在本地使用disconnect命令,如下:

  2500#disconnect
  <1-2> The number of an active network connection
  WORD The name of an active network connection
  <cr>
  2500#disconnect 1
  Closing connection to 172.16.10.2 [confirm]
  2500#
  
  验证如下:
  2600#sh users
  Line User Host(s) Idle Location
  *0 con 0 idle 0
  1 aux 0 idle 0
  2 vty 0 idle 172.16.10.1
  清除连接,使用clear line命令,并验证,如下:
  2600#clear line 2
  [confirm]
  [OK]
  2600#sh users
  Line User Host(s) Idle Location
  *0 con 0 idle 0
  1 aux 0 idle 1
  2600#
  
  解析主机名
  2种解析主机名到IP地址的办法:
  1.在每个router上建立主机表(host table)
  2.建立DNS服务器(Domain Name System server),这个类似动态主机表
  建立主机表
  主机表只提供包含其中的解析,建立主机表的命令是ip host [主机名] [TCP端口号] [IP地址],默认TCP端口号为23.1个主机可以对应最多8个IP地址.如下:
  2500(config)#ip host 2501B 172.16.10.2
  2500(config)#ip host 1900S 192.168.0.32
  2500(config)#^Z
  使用show hosts命令验证新建的主机表,如下:
  2500#sh hosts
  Default domain is not set
  Name/address lookup uses domain service
  Name servers are 255.255.255.255
  Host Flags Age Type Address(es)
  2501B (perm, OK) 0 IP 172.16.10.2
  1900S (perm, OK) 0 IP 192.168.0.32
  2500#
  注重Flags选项的perm,代表是手动输入的,假如这项是temp的话,表明是由DNS解析的
  使用DNS解析名称
  假如你在CLI下输入了1个Cisco设备不能识别的命令,它会默认通过DNS来进行解析(它认为是主机名).这个不好的地方是要花费额外的时间等待DNS解析完.可以在全局配置模式下使用no ip domain-lookup命令关闭它
  
  假如你在你的网络里有DNS服务器,可以使用1些命令使DNS解析开始工作:
  1.第一条命令是:ip domain-lookup,这个命令默认是打开了的.假如你之前使用了no ip domain-lookup的话,就要用这条命令打开它
  2.第二条命令是:ip name-server.设置DNS服务器的IP地址,可以使1个IP地址对应多达6个服务器
  3.最后条命令是:ip domain-name.虽然这个命令是可选的,但是最好还是设置1下
  实例如下:
  2500(config)#ip domain-lookup
  2500(config)#ip name-server 192.168.0.23
  2500(config)#ip domain-name noko.com
  2500(config)#^Z
  2500#
  可以使用ping命令来严正下,如下:
  2500#ping 1900S
  Translating “1900S”…domain server (192.168.0.23) [OK]
  (略)
  使用show hosts命令验证下,如下:
  2500#sh hosts
  Default domain is noko.com
  Name/address lookup uses domain service
  Name servers are 192.168.023
  Host Flags Age Type Address(es)
  2501B (perm, OK) 0 IP 172.16.10.2
  1900S.noko.com (temp, OK) 0 IP 192.168.0.32
  2500#
  检查网络连接
  使用ping命令和Traceroute命令
  __________________
  WEB:www.cc-ie.com/bbs 互联神州CCIE实验室论坛
  Q Q:95554545
  MSN:fumin_0830@hotmail.com
  
  2005-05-13, 19:01 #9
  
  互联神州-小菜鸟
  查看公开信息
  发送静静话给互联神州-小菜鸟
  查找互联神州-小菜鸟发表的更多帖子
  添加 互联神州-小菜鸟 到好友列表
  
  互联神州-小菜鸟
  此人以死 有事烧香 无事烧纸
  
  注册日期: Apr 2005
  来自: 成都
  帖子: 950
  回复: 【原创】CCNA网络小菜鸟笔记,两天才整理完的
  
  --------------------------------------------------------------------------------
  
  第十章, 使用访问列表治理流量
  
  访问列表可以用于答应或拒绝包通过路由器、答应或拒绝Telnet(VTY)访问路由器、答应或拒绝来自路由器的Telnet访问,以及创建可以出发拨号到远程站点的流量。
  访问列表简介
  访问列表基本上是一系列对包进行分类的条件。
  一个最常用和最轻易理解的使用访问列表的情况是,实现安全策略时过滤不希望通过的包。

  
  数据包和访问列表向比较时遵循的重要规则:
  1. 通常是按顺序比较访问列表的每一行。
  2. 比较访问列表的各行直到比较到匹配的一行。
  3. 在每个访问列表的最后是一行隐含“deny”语句-意味着假如数据包与访问列表中的所有行都不匹配,将被丢弃。
  
  访问列表有两种类型:
  1. 标准的访问列表
  2. 扩展的访问列表
  3. 命名的访问列表(基于标准和扩展之间的)
  
  在一个接口的输入方向和输出方向使用不同的访问列表:
  1. 输入型访问列表 党访问列表被应用刀从接口输入的包时,那些包在被路由到输出接口之前要经过访问列表的处理。
  2. 输出行访问列表 当访问列表被应用到从接口输出的包时,那些包首先被路由到输出接口,然后在进入该接口的输入队列之前经过访问列表的处理。
  
  标准的访问列表
  标准的IP访问列表通过使用IP包中的源IP地址过滤网络流量。可以使用访问列表号1-99或130-1999创建标准的访问列表。一般用号码区别访问列表类型。
  
  通配符
  通配符和访问列表一起用来指定一个主机、一个网络、一个网络或几个网络内的某个范围。
  要理解通配符,需要理解什么是块大小,这里经常指地址范围。一些有效的块大小是64、32、16、8和4。
  简单的描述,通配符相当于是子网掩码,不过刚好相反,0表示绝对匹配,1表示任意匹配。
  
  标准的访问列表举例:
  Lab_A#config t
  Lab_A(config)#access-list 10 deny 172.16.40.0 0.0.0.255
  Lab_A(config)#access-list 10 permit any
  
  这个访问控制列表的意思是,拒绝所有172.16.40.0这个网段的数据
  其他的数据都答应通过。
  扩展的访问控制列表
  扩展的访问列表答应指定源地址和目的地址,以及表示上层协议或应用的协议和端口号。通过使用扩展的IP访问列表,可以有效地答应用户访问物理
  LAN的同时不答应访问特定的主机或甚至那些主机上的特定服务。
  
  扩展的访问列表举例:
  Lab_A#config
  Lab_A(config)#access-list 110 deny tcp any host 172.16.30.5 eq 21
  Lab_A(config)#access-list 110 deny tcp any host 172.16.30.5 eq 23
  Lab_A(config)#access-list 110 permit ip any any
  第一行和第二行意思是,拒绝所有目的地址是172.16.30.5的FTP访问和Telnet访问
  第三行意思是,答应所有的数据通过。
  
  第十一章, 广域网协议
  
  定义WAN术语:
  1. Customer premises equipment,CPE(用户驻地设备)
  2. Demarcation point(分界点)
  3. Local loop(本地回路)
  4. Central Office(中心局)
  5. Toll network(长途网络)
  
  WAN连接类型
  WAN可以使用许多不同的连接类型,这里只介绍市场上常见的各种WAN连接类型。
  1. 专线
  2. 电路交换
  3. 分组交换
  
  下面解释WAN连接类型:
  1. 租用线路 租用线路典型地指点导电连接或专线连接。
  2. 电路交换 电路交换的最大优势就是成本低。在端到端连接之前不能传输数据。电路交换使用拨号调制解调或ISDN,用于低带宽数据传输。
  3. 包交换 答应和其他公司共向带宽以节省资金。假如需要经常传输数据,则不咬考虑这种类型,应当使用租用线路。
  
  WAN支持
  1. 帧中继
  2. ISDN
  3. LAPB
  4. HDLC
  5. PPP
  6. ATM
  
  WAN布线
  Cisco串行连接几乎支持WAN服务的任何类型。典型的WAN连接是使用HDLC、PPP、综合业务数字网和帧中继专线。
  HDLC、PPP和帧中继可以使用同一种物理规范,但是ISDN在物理层有各种不相同的输出引脚和规范。
  
  串行传输
  WAN串行连接器使用串行传输,即一个信道一个时间只传输一位。
  Cisco路由器使用专用的60针串行连接器,这种连接器只能从Cisco或Cisco设备服务提供商获得。
  电缆另一端的连接器类型依靠于服务提供商或所需的终端设备。
  各种可用的设备有:
  1. EIA/TIA-232
  2. EIA/TIA-499
  3. V.35
  4. X.21
  5. EIA-530
  
  数据终端设备(DTE)和数据通信设备(DCE)
  路由器接口默认情况下是数据终端设备(DTE),连接着数据通信设备(DCE)。
  WAN的思想是能够通过DCE网络将两个DTE网络连接在一起。
  
  固定接口和模块化接口
  固定接口的路由器,如2500系列,具有不能更换的一套接口。1600、1700、2600、3600以及更高系列的路由器都具有模块化的接口,即答应你购买现在所需的接口并增加以后可能需要的任何类型的接口。
  
  高级数据链路控制协议
  HDLC是流行的ISO标准、面向位的数据链路层协议。它使用帧特性和效验和规定数据在同步串行数据链路上封装的方法。HDLC是一种用于租用线路的点到点协议。
  在面向字节协议中,用整个字节对控制信息进行编码。
  
  点到点协议
  PPP是一种可以用于异步拨号或同步穿行介质的数据链路层协议。他使用LCP建立并维护数据链路连接。
  PPP包含的主要组件:
  EIA/TIA-232-C、V.24、V.35V和ISDN
  HDLC
  LCP
  NCP
  
  链路控制协议配置选项
  链路控制协议提供各种PPP封装选项:
  1. Authentication(认证)
  2. Compression(压缩)
  3. Error detection (错误检测)

  4. Multilink(多链路)
  5. PPP回叫
  
  PPP会话建立
  当PPP连接开始时,连路经过三个会话建立阶段:
  链路建立阶段 每个PPP设备发送LCP包来配置和测试连路。
  认证阶段 假如配置了认证,在人证链路时可以使用CHAP或PAP。认证发生在读取网络层协议信息之前。
  
  PPP认证方法
  PPP链路可以使用两种认证方法:
  口令认证协议(PAP) 口令认证协议是两种方法中安全程度较低的一种。口令以明文发送,并且PAP值在初始链路建立时执行。
  问答握手认证协议(CHAP) 问答握手认证协议用于链路初始启动,和为了证实路由器连接的仍然是同一个主机而进行周期性链路检查。
  在Cisco路由器上配置PPP
  Router#config t
  Enter configuration commands, one per line. End with CNTL/Z.
  Router(config)#int s0
  Router(config-if)#encapsulation ppp
  Router(config-if)#^Z
  Router#
  
  配置PPP认证
  将串行接口配置为支持PPP封装后,可以使用PPP在路由器之间配置认证。
  Router#config t
  Enter configuration commands, one per line. End with CNTL/Z.
  Router(config)#hostname RouterA
  RouterA(config)#username RouterB password 12345
  当使用hostname命令时,要记住用户名师连接你路由器的远程路由器的主机名。
  当设置了主机名、用户名和口令后,选择认证类型、CHAP和PAP:
  RouterA#config t
  Enter configuration commands, one per line. End with CNTL/Z.
  RouterA(config)#int s0
  RouterA(config-if)#ppp authentication chap pap
  RouterA(config-if)#^Z
  RouterA#
  
  验证PPP封装
  使用show interface命令来验证配置。
  帧中继
  帧中继是从x.25技术发展来的。
  帧中继技术简介
  帧中继是包交换技术。
  1. 不能使用encapsulation hdlc或encapsulation ppp命令进行配置。
  2. 帧中继和点到点租用线路不一样。
  3. 帧中继在许多情况下没有租用线路昂贵,但未了节省费用会有些损失。
  
  帧中继技术
  首先要知道这种技术的工作原理。
  工作过程如下:
  1. 用户网络主机在本地网络发送一个帧。
  2. 路由器获得此帧,提取出数据包,丢弃剩下的帧。
  3. 路由器然后从它认为可以找到远程网络的接口转发此数据。
  4. 信道服务单元/数据服务单元(CSU/DSU)接收数字信号,并将信号编码为包交换机(PSE)可以理解的数字信号类型。
  5. CSU/DSU连接分界,分解由服务提供商安装并且位于服务提供商的第一个负责点。
  6. 典型的分解时连接到本地回路的双绞线电缆。
  7. CO接收帧并通过帧中继“网云”发送到他的目的地。
  8. 一旦帧到达最靠近目的交换局,就发送到本地回路上。
  
  承诺信息率(CIR)
  帧中继提供商同时为许多不能得客户提供包交换网络。
  正中及通过每个用户提供部分专用带宽工作,并在电信网络有可用资源的情况下答应用户超过他们保证的带宽。
  访问速率(Access rate) 帧中继接口可以传输的最大速率。
  CIR 数据传输承诺的最大速率。
  
  帧中继封装类型
  当在Cisco路由器上配置帧中继时,需要在串行接口上将帧中继指定为一种封装。
  RouterA(config)#int s0
  RouterA(config-if)#encapsulation frame-relay
  ietf Use RFC1490/RFC2427 encapsulation
  <cr>
  除非手的输入ietf,否则默认的封装是Cisco,而且连接两个Cisco设备时使用Cisco类型。
  
  虚电路
  帧中继使用虚电路工作方式,对英语租用线路使用的真正电路。这些虚电路是连接到提供商“网云”上的几千个设备构成的链路。
  
  本地治理接口
  本地治理接口是路由器和它所连接的第一个帧中继交换机之间使用的信令标准。
  它传输下列有关信息:
  1. 保持激活
  2. 组播
  3. 全局寻址
  4. 虚电路状态
  
  帧中继拥塞控制
  CIR设置的越低,数据被丢弃的危险就越大。
  三种拥塞位和其意义:
  1. 丢弃合格
  2. 向前显示拥塞通知
  3. 向后显示拥塞通知
  帧中继的试验和监控
  
  单个接口
  RouterA#config
  05:41:11: %SYS-5-CONFIG_I: Configured from console by consolet
  Enter configuration commands, one per line. End with CNTL/Z.
  RouterA(config)#int s0
  RouterA(config-if)#encapsulation frame-relay
  RouterA(config-if)#ip addr 172.16.20.1 255.255.255.0
  RouterA(config-if)#frame-relay lmi-type ansi
  RouterA(config-if)#frame-relay interface-dlci 101
  RouterA(config-fr-dlci)#^Z
  
  子接口
  可能在一个串行接口上有多条虚电路,并且将每个虚电路视为一个单独的接口,他被认为是子接口。

  可以用int s0.subinterface number命令定义子接口。
  
  点到点
  当一个虚电路连接一个路由器到另一个路由时使用点到点子接口。
  
  多点
  档路由器位于星型虚电路的中心时使用多点子接口。
  
  综合业务数字网
  ISDN是一种在现有电话网上运行的数字服务。
  PPP典型地用于ISDN,提供数据传输、链路集成和认证。
  ISDN的优势有:
  1. 可以同时承载语音、视频和数据。
  2. 胡椒和建立比模拟调制解调器要快。
  3. 数据传输率比模拟调制解调器连接要高。
  4. ISDN上的全时连接是由Cisco IOS路由器使用按需拨号路由技术造成的假象。
  5. 使用ISDN BRI业务可以非常经济地支持小型办公室和家庭办公室站点。
  6. 调制解调器的机架放置和布线问题可以通过在Cisco IOS网络接入服务器上集成数字调制解调器卡莱解决。
  
  ISDN连接
  ISDN是由两个64K的B信道和一个用于传输信令的16K的D信道组成。
  ISDN BRI 路由器有一个U接口或一个S/T接口。
  
  ISDN组件
  ISDN使用的组件包括功能和参考点。
  
  ISDN终端
  连接到ISDN网络的设备是终端设备(TE)和网络终端(NT)设备。美中设备有两种类型:
  1. TE1
  2. TE2
  3. NT1
  4. NT2
  5. TA
  
  ISDN参考点
  参考电视一系列规范,定义用于ISDN网络中的各种设备之间的连接。ISDN有四种定义逻辑接口的参考点:
  1.R R参考点定义非ISDN设备(TE2)和TA之间的连接点。
  2.S S参考点定义客户路由器和NT2之间的连接点。
  3.T T参考点定义NT1和NT2设备之间的连接点。
  4.U U参考点定义NT1设备和载波网络中的线路终端设备之间的连接点。
  
  基本速率接口
  ISDN基本速率接口业务,也叫做2B+D,提供两个B信道和一个D信道,BRI的总带宽是144Kb/s
  要设置BRI胡椒,必须经过四个步骤:
  1. 路由器和本地ISDN交换机之间的D信道连接。
  2. ISDN交换机使用SS7信令技术建立到远程交换机的路径。
  3. 然后B信道连接端对端。
  
  基群速率接口
  ISDN基群速率接口业务提供23个64Kb/s B信道和一个64Kb/s D信道,PRI的总带宽是2.048Mb/s
  
  ISDN和Cisco路由器
  对于每个ISDN BRI接口,需要使用isdn spid1和isdn spid2接口子命令指定SPID。
  SPID配置的第二部分是那个SPID的本地拨号号码。
  
  按需拨号路由选择
  按需拨号路由选择用于答应两个或多个Cisco路由器在需要时使用ISDN拨号连接。
  当接口接收到数据包符合治理员设定的访问列表的要求时DDR才工作。
  5个步骤基本描述了党路由器接收到一个触发DDR的数据包时DDR是如何工作的:
  1. 决定通过拨号连接到目的网络的路由。
  2. 触发DDR的数据包指示一个DDR呼叫。
  3. 查找拨号信息并进行拨号。
  4. 传输流量。
  5. 当链路上没有流量并且空闲超时时间到时胡椒结束。
  
  配置DDR
  配置DDR,需要执行三个任务:
  1. 定义静态路由,定义如何到达远程网络以及通过什么接口到达。
  2. 为路由器指定触发DDR的流量。
  3. 配置拨号信息,拨号连接到达远程网络的接口时将使用此号码。
  
  配置静态路由
  创建静态路由时牢记下列问题:
  1. 所有参与的路由器必须都有定义所有已知网络的静态路由。
  2. 可以在存根网络中使用默认路由。
  创建静态路由例子:
  RouterA(config)#ip route 172.16.50.0 255.255.255.0 172.16.60.2
  RouterA(config)#ip route 172.16.60.2 255.255.255.255 bri0
  这样做是告诉路由器通过172.16.60.2可以到达网络172.16.50.0。第二行告诉路由器如何到达172.16.60.2。
  
  指定触发DDR的流量
  在每个路由器上设置了路由表以后,需要配置路由器决定什么流量启动ISDN线路。
  RouterA(config)#dialer-list 1 protocol ip permit
  RouterA(config)#int bri0
  RouterA(config-if)#dialer-group 1
  Dialer-group在BRI接口上设置访问列表。
  
  配置拨号信息
  配置拨号信息有五个步骤:
  1. 选择接口。
  2. 设置IP地址。
  3. 配置封装类型。
  4. 在接口上设置触发DDR的流量。
  5. 配置一个或多个拨号号码。
  
  五个步骤地例子:
  RouterA#config
  Enter configuration commands, one per line. End with CNTL/Z.
  RouterA(config)#int bri0
  RouterA(config-if)#ip addr 172.16.60.1 255.255.255.0
  RouterA(config-if)#no shut
  RouterA(config-if)#encapsulation ppp
  RouterA(config-if)#dialer-group 1
  RouterA(config-if)#dialer string 8350661
  不用dialer string命令,可以使用Dialer map命令,他提供更好的安全性。
  RouterA(config-if)#dialer map ip 172.16.60.2 name RouterB 8350661
  Dialer map命令可以和dialer-group命令及其相关的访问列表一起使用以初始化拨号。

  必须知道的五个基本拨号影射步骤是:
  1. Dialer
  2. Map
  3. 协议
  4. 下一跳
  5. 号码串
  
  可选命令
  Dialer load-threshold
  Dialer idle-timeout
  Dialer load-threshold命令告诉BRI接口什么时候启用第二个B信道。
  Dialer idle-timeout命令指定在发送完最后一个触发DDR的流量之后到断开呼叫之前的秒数。
  DDR和访问列表
  RouterA(config)#dialer-list 1 protocol ip list 110
  RouterA(config)#access-list 110 permit tcp any any eq smtp
  RouterA(config)#access-list 110 permit tcp any any eq telnet
  RouterA(config)#int bri0
  RouterA(config-if)#dialer-group 1
  这里不一定必须是IP协议,可以使用任何协议。
  创建拨号列表,然后用dialer-group命令应用到BRI接口。