路由协议-OSPF路由协议

1/23/2008来源:网络协议人气:10843

5.3     OSPF路由协议. 1

5.3.1    OSPF的基本配置. 1

5.3.2     关于ospf network-type的配置原则. 4

5.3.3     复杂些的多域OSPF配置. 4

5.3.4     配置OSPF聚合. 7

5.3.5     使用stub区. 10

5.3.6     使用完全stub区. 12

5.3.7     使用nssa 15

5.3.8    ospf的邻居认证配置. 18

5.3.9    ospf 虚连接的配置. 18

 

5.3   OSPF路由协议

5.3.1   OSPF的基本配置

『需求』

 

两台pc所在网段,通过两台使用OSPF协议的路由器实现互连互通。

 

 

第一种实现方法:

 

【Router A】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

[Router]

!

适用版本:vrp1.74及1.44

[Router]

router id 10.1.1.1

配置router id

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-Ethernet0]

ip address 10.1.1.1 255.255.255.0

配置内网IP地址

[Router-Ethernet0]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

[Router]

interface Serial0

进入串口0口

[Router-Serial0]

link-PRotocol ppp

封装ppp协议

[Router-Serial0]

ip address 20.1.1.2 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

 

quit

 

[Router]

ospf enable

启动ospf路由协议

 

!

 

 

 

 

【Router B】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

[Router]

!

适用版本:vrp1.74及1.44

[Router]

router id 30.1.1.1

配置router id

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-Ethernet0]

ip address 30.1.1.1 255.255.255.0

配置内网IP地址

[Router-Ethernet0]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

[Router]

interface Serial0

进入串口0口

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 20.1.1.1 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

 

quit

 

[Router]

ospf enable

启动ospf路由协议

 

!

 

 

第二种方法:

 

【Router A】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

[Router]

!

适用版本:vrp1.74及1.44

[Router]

router id 10.1.1.1

配置router id

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-Ethernet0]

ip address 10.1.1.1 255.255.255.0

配置内网IP地址

 

!

 

[Router]

interface Serial0

进入串口0口

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 20.1.1.2 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

 

quit

 

[Router]

ospf enable

启动ospf路由协议

[Router-ospf]

import-route direct 

引入直连路由

 

!

 

 

 

 

【Router B】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

[Router]

!

适用版本:vrp1.74及1.44

[Router]

router id 30.1.1.1

配置router id

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-Ethernet0]

ip address 30.1.1.1 255.255.255.0

配置内网IP地址

 

!

 

[Router]

interface Serial0

进入串口0口

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 20.1.1.1 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

 

quit

 

[Router]

ospf enable

启动ospf路由协议

[Router-ospf]

import-route direct

引入直连路由

 

!

 

 

『说明』

以上两种方法均能实现两台PC互通的需求;上面仅给出实现方法的具体配置,至于组网方式的确定,请参考其他OSPF协议组网资料。

5.3.2   关于ospf network-type的配置原则

Quidway路由器的网络类型缺省如下

 

ospf网络类型

链路层协议

p2p

PPP

NBMA

fr,x25,HDLC

p2mp

broadcast

Ethernet

 

『注重』

 

互连的路由器网络类型必须一致。

NBMA和p2mp的,必须在接口下配置:

[Router-Serial0]ospf peer 20.1.1.2

5.3.3   复杂些的多域OSPF配置

『需求』

 

在一个OSPF自治系统中ABR的配置情况。A,B运行在area 0;B,C运行在area 1,B为ABR

 

 

【Router A】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 10.1.1.1

配置router id

 

 

!

 

 

[Router]

interface Ethernet0

进入以太0口

 

[Router-Ethernet0]

ip address 10.1.1.1 255.255.255.0

配置内网IP地址

 

[Router-Serial1]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

 

!

 

 

[Router]

interface Serial0

进入串口0口;连Router B

 

[Router-Serial1]

link-protocol ppp

封装ppp协议

 

[Router-Serial1]

ip address 20.1.1.2 255.255.255.252

配置串口IP地址

 

[Router-Serial1]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

 

!

 

 

 

quit

 

 

[Router]

ospf enable

使能ospf

 

 

!

 

 

 

 

【Router B】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 30.1.1.1

配置router id

 

 

!

 

[Router]

interface Serial0

进入串口0口;连Router C

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 30.1.1.1 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial1

进入串口0口;连Router A

[Router-Serial1]

link-protocol ppp

封装ppp协议

[Router-Serial1]

ip address 20.1.1.1 255.255.255.252

配置串口IP地址

[Router-Serial1]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

 

!

 

 

 

【Router C】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 40.1.1.1

配置router id

 

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-Ethernet0]

ip address 40.1.1.1 255.255.255.0

配置内网IP地址

[Router-Ethernet0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial0

进入串口0口;连Router B

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 30.1.1.2 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.1

接口使能ospf,属于0域

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

 

!

 

 

5.3.4   配置OSPF聚合

『需求』

 

在一个OSPF自治系统中ABR的配置情况。A,B运行在area 0;B,C运行在area 1,B为ABR

Router C上有两个接口配置了ospf enable area 1,他们分别是40.1.1.0/24和40.1.2.0/24网段

要求ABR Router C上做路由聚合,将上两个网段聚合为一个网段

 

 

【Router A】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 10.1.1.1

配置router id

 

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-ethernet0]

ip address 10.1.1.1 255.255.255.0

配置内网IP地址

[Router-ethernet0]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

[Router]

interface Serial0

进入串口0口;连Router B

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 20.1.1.2 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

 

!

 

 

 

 

【Router B】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 30.1.1.1

配置router id

 

 

!

 

[Router]

interface Serial0

进入串口0口;连Router C

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 30.1.1.1 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial1

进入串口0口;连Router A

[Router-Serial1]

link-protocol ppp

封装ppp协议

[Router-Serial1]

ip address 20.1.1.1 255.255.255.252

配置串口IP地址

[Router-Serial1]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

[Router-ospf]

abr-summary 40.1.0.0 mask 255.255.0.0  area

 0.0.0.1

ABR路由器将1域的包含在40.1.0.0/16内的网段聚合

 

!

 

 

 

 

【Router C】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 30.1.1.1

配置router id

 

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-ethernet0]

ip address 40.1.1.1 255.255.255.0

配置内网IP地址

[Router-ethernet0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Ethernet1

进入以太1口

[Router-ethernet1]

ip address 40.1.2.1 255.255.255.0

配置内网IP地址

[Router-ethernet1]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial0

进入串口0口;连Router B

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 30.1.1.2 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

 

!

 

 

『注重』

 

路由聚合只能配置在ABR上。

路由聚合对组网也提出了要求:同一非骨干域的网段请尽量连续可聚合。否则以后网络扩容,维护难度加大很多。

5.3.5   使用stub区

『需求』

 

一个OSPF自治系统中,A,B运行在area 0 ,B,C运行在area 1,且为stub区域,B为ABR

router C引入到D的外部路由,area 1可以去往D,除area 1的其他区域无法访问D

 

【Router A】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 10.1.1.1

配置router id

 

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-ethernet0]

ip address 10.1.1.1 255.255.255.0

配置内网IP地址

[Router-ethernet0]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

[Router]

interface Serial0

进入串口0口;连Router B

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 20.1.1.2 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.0

接口使能ospf,属于1域

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

 

!

 

 

 

 

【Router B】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 10.1.1.1

配置router id

 

 

!

适用版本:vrp1.74

[Router]

interface Seria0

进入串口0口;连Router C

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 30.1.1.1 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial1

进入串口0口;连Router A

[Router-Serial1]

link-protocol ppp

封装ppp协议

[Router-Serial1]

ip address 20.1.1.1 255.255.255.252

配置串口IP地址

[Router-Serial1]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

[Router-ospf]

stub cost 60 area 0.0.0.1

将1域配置成为stub域

 

!

 

 

 

 

『Router C』

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 40.1.1.1

配置router id

 

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-ethernet0]

ip address 40.1.1.1 255.255.255.0

配置内网IP地址

[Router-ethernet0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial0

进入串口0口;连Router B

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 30.1.1.2 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial1

进入串口1口;连D

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 1.1.1.2 255.255.255.252

配置串口IP地址

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

[Router-ospf]

stub cost 60 area 0.0.0.1

将1域配置为stub域

[Router-ospf]

import-route static

引入静态路由

 

!

 

 

quit

 

 

ip route-static 50.0.0.0 255.0.0.0 1.1.1.1 preference 60

配置去往D的静态路由

 

5.3.6   使用完全stub区

『需求』

 

一个OSPF自治系统中,A,B运行在area 0 ,B,C运行在area 1,且为stub区域,B为ABR

router C引入到D的外部路由,area 1和area 1之外的其他区域无法访问D

 

【Router A】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74

 

[Router]

router id 10.1.1.1

配置router id

 

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-ethernet0]

ip address 10.1.1.1 255.255.255.0

配置内网IP地址

[Router-ethernet0]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

[Router]

interface Serial0

进入串口0口;连Router B

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 20.1.1.2 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.0

接口使能ospf,属于1域

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

 

!

 

 

 

 

【Router B】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74

 

[Router]

router id 10.1.1.1

配置router id

 

 

!

适用版本:vrp1.74

[Router]

interface Seria0

进入串口0口;连Router C

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 30.1.1.1 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial1

进入串口0口;连Router A

[Router-Serial1]

link-protocol ppp

封装ppp协议

[Router-Serial1]

ip address 20.1.1.1 255.255.255.252

配置串口IP地址

[Router-Serial1]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

[Router-ospf]

stub cost 60 area 0.0.0.1 no-summary

将1域配置成为完全stub域

 

!

 

 

 

 

【Router 】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 40.1.1.1

配置router id

 

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-ethernet0]

ip address 40.1.1.1 255.255.255.0

配置内网IP地址

[Router-ethernet0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial0

进入串口0口;连Router B

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 30.1.1.2 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial1

进入串口1口;连D

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 1.1.1.2 255.255.255.252

配置串口IP地址

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

[Router-ospf]

stub cost 60 area 0.0.0.1 no-summary

将1域配置为完全stub域

[Router-ospf]

import-route static

引入静态路由

 

!

 

 

quit

 

 

ip route-static 50.0.0.0 255.0.0.0 1.1.1.1 preference 60

配置去往D的静态路由

 

『注重』

 

请注重版本适用范围。

 

5.3.7   使用nssa

『需求』

 

一个OSPF自治系统中,A,B运行在area 0,B,C运行在area 1,且为NSSA区域,B为ABR。

整个OSPF自治系统均可学习到asbr router C引入的到D的路由。

 

【Router A】

 

 

【Router A】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 10.1.1.1

配置router id

 

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-ethernet0]

ip address 10.1.1.1 255.255.255.0

配置内网IP地址

[Router-ethernet0]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

[Router]

interface Serial0

进入串口0口;连Router B

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 20.1.1.2 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.0

接口使能ospf,属于1域

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

 

!

 

 

 

 

【Router B】

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 10.1.1.1

配置router id

 

 

!

适用版本:vrp1.74

[Router]

interface Seria0

进入串口0口;连Router C

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 30.1.1.1 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial1

进入串口0口;连Router A

[Router-Serial1]

link-protocol ppp

封装ppp协议

[Router-Serial1]

ip address 20.1.1.1 255.255.255.252

配置串口IP地址

[Router-Serial1]

ospf enable area 0.0.0.0

接口使能ospf,属于0域

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

[Router-ospf]

nssa area 0.0.0.1

将1域配置成为nssa域

 

!

 

 

 

 

『Router C』

 

当前路由器提示视图

依次输入的配置命令,重要的命令红色突出显示

简单说明

 

!

适用版本:vrp1.74及1.44

 

[Router]

router id 40.1.1.1

配置router id

 

 

!

 

[Router]

interface Ethernet0

进入以太0口

[Router-ethernet0]

ip address 40.1.1.1 255.255.255.0

配置内网IP地址

[Router-ethernet0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial0

进入串口0口;连Router B

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 30.1.1.2 255.255.255.252

配置串口IP地址

[Router-Serial0]

ospf enable area 0.0.0.1

接口使能ospf,属于1域

 

!

 

[Router]

interface Serial1

进入串口1口;连D

[Router-Serial0]

link-protocol ppp

封装ppp协议

[Router-Serial0]

ip address 1.1.1.2 255.255.255.252

配置串口IP地址

 

!

 

 

quit

 

[Router]

ospf enable

使能ospf

[Router-ospf]

nssa area 0.0.0.1

将1域配置为nssa域

[Router-ospf]

import-route static

引入静态路由

 

!

 

 

quit

 

 

ip route-static 50.0.0.0 255.0.0.0 1.1.1.1 preference 60

配置去往D的静态路由

 

5.3.8   ospf的邻居认证配置

互连的路由器的接口下配置

明文认证:

[RouterA-Ethernet0] ospf authentication-mode simple quidway

 

md5加密认证:

[RouterA-Serial0] ospf authentication-mode md5 huawei 11

5.3.9   ospf 虚连接的配置

『需求』

 

普通area 1为transit-area,连接着area 0和area 2

 

 

基本的配置如前所述,需要增加的配置如下

【Router B】

 

[Router-ospf]vlink peer-id 30.1.1.2 transit-area 0.0.0.1

 

【Router C】

 

[Router-ospf]vlink peer-id 30.1.1.1 transit-area 0.0.0.1

 

『注重』

虚连接的组网请尽量避免!

虚连接无法穿过stub域和nssa域。

    附件

路由协议-ospf路由协议.doc