华为8016交换机DHCP配置

3/1/2008来源:华为网络人气:5937

1         功能需求及组网说明

 
8016DHCP配置
『配置环境参数』
1.      DHCP server的ip地址192.168.0.10/24
2.      DHCP server连接在交换机G1/0/0,属于vlan100,网关即vlan100虚接口地址192.168.0.1/24
3.      交换机通过G1/0/1连接SwitchAG1/1,G1/0/2连接SwitchBG1/1
4.      SwitchA通过G2/1连接SwitchC G1/1
5.      vlan10的用户网段为10.10.1.1/24
6.      vlan20的用户网段为10.10.2.1/24
7.      vlan30的用户网段为10.10.3.1/24
8.      SwitchA和SwitchC为二层交换机,SwitchB为三层交换机
『组网需求』
1.      8016作DHCP relay,利用远端DHCP server为SwitchA下面的vlan10分配IP地址
2.      SwitchB上的vlan20用户以8016上的vlan20虚接口为网关,8016作DHCP server直接为其分配IP地址
3.      SwitchC上的vlan30用户以SwitchB上的vlan30虚接口为网关,8016作DHCP server为其分配IP地址

2         数据配置步骤

『8016DHCP relay数据流程』
DHCP Relay的作用则是为了适应客户端和服务器不在同一网段的情况,通过Relay,不同子网的用户可以到同一个DHCP server申请IP地址,这样便于地址池的治理和维护。
【8016DHCP relay配置】
1.      DHCP server要配置到一个VLAN上,这个VLAN可以是任意的,但是要实现Relay,不要将Server同任何客户端配置到同一个VLAN内,建议专门划出VLAN给DHCP server组使用,这里将DHCP服务器组1对应的端口的VLAN配置为100。
[Quidway] vlan 100
[Quidway-vlan100] port gigabitethernet 1/0/0
[Quidway] interface vlanif 100
2.      配置DHCP server的网关地址
[Quidway-Vlanif100] ip address 192.168.0.1 255.255.255.0
3.      配置DHCP服务器组1对应的IP地址。
[Quidway] dhcp relay server-group 1 server 192.168.0.10
4.      配置DHCP服务器组1服务的VLAN范围为10
[Quidway] dhcp relay server-group 1 vlan 10
5.       进入G1/0/1,设置为trunk端口,答应vlan10通过
[Quidway-gigabitethernet 1/0/1] port trunk permit vlan 10
6.      配置VLAN10的对应网关地址。
[Quidway] interface vlanif 10
[Quidway-Vlanif10] ip address 10.10.1.1 255.255.255.0
 
『8016作DHCP server数据流程』
内置DHCP server下挂的用户类型有两种:一种是S8016的VLAN用户,用户直接向S8016发起DHCP请求,这类称为VLAN地址池用户;另一种是中间经过了DHCP中继设备(例如MA5200设备),DHCP请求在到达S8016之前经过了DHCP relay,这类称为全局地址池用户。
 
【8016vlan用户】
1.      用户所在VLAN ID为20,创建并进入VLAN配置视图。
[Quidway] vlan 20
2.      将VLAN 20用户地址分配方式设置为本地。
[Quidway-vlan20] address allocate local
3.      配置VLAN 20接口IP地址10.10.2.1,同时指定了DHCP server可分配的地址资源为10.10.2.0~10.10.2.255。

[Quidway] interface vlan 20
[Quidway-Vlanif20] ip address 10.10.2.1 255.255.255.0
4.      S8016下挂了一台DNS服务器,IP地址是10.10.2.15,在S8016中设置DNS服务器的IP地址,同时将这个IP地址在地址池中禁止分配给用户。
[Quidway-vlan2] dhcp server forbidden-ip 10.10.2.15
[Quidway-vlan2] dns PRimary-ip 10.10.2.15
5.       进入G1/0/2,设置为trunk端口,答应vlan20通过
[Quidway-gigabitethernet 1/0/2] port trunk permit vlan 20
 
【全局地址用户】
1.      创建全局地址池,并命名为“abc”,地址池用户网关地址为10.10.30.1
[Quidway] dhcp server ip-pool abc  10.10.3.1 255.255.255.0
2.      配置路由IP信息
[Quidway] dhcp server gateway abc 10.10.3.1
3.      S8016下挂了另外一台DNS服务器,IP地址是10.10.3.15,在S8016中设置DNS服务器的IP地址,同时将这个IP地址在地址池中禁止分配给用户。
[Quidway] dns primary-ip abc 10.10.3.15
[Quidway] dhcp server forbidden-ip abc 10.10.3.15
4.      配置VLAN200与SwitchB相应的虚接口vlan200在同一个网段
[Quidway] interface vlanif 200
[Quidway-Vlanif200] ip address 10.10.10.1 255.255.255.0
 
【SwitchB相关配置】
1.      创建(进入)vlan30
[SwitchB] vlan 30
2.      将E0/1加入到vlan30
[SwitchB-vlan30]port Ethernet 0/1
3.      实际当中一般将上行端口设置成trunk属性,答应vlan透传
[SwitchB-GigabitEthernet2/1]port link-type trunk
4.      答应SwitchC的vlan从G2/1端口透传通过
[SwitchB-GigabitEthernet2/1]port trunk permit vlan 30
5.      实际当中一般将上行端口设置成trunk属性,答应vlan透传
[SwitchB-GigabitEthernet1/1]port link-type trunk
6.      答应所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值
[SwitchB-GigabitEthernet1/1]port trunk permit vlan 30
7.      创建(进入)vlan30的虚接口
[SwitchB]interface Vlan-interface 30
8.      给vlan30的虚接口配置IP地址
[SwitchB-Vlan-interface30]ip address 10.10.3.1 255.255.255.0
[SwitchB]
9.      定义一个DHCP server
[SwitchB]dhcp-server 0 ip 10.10.10.1
[SwitchB-Vlan-interface30]dhcp-server  0
10.  创建(进入)vlan200的虚接口,vlan200用于SwitchB与8016互连
[SwitchB]interface Vlan-interface 200
11.  给vlan200的虚接口配置IP地址
[SwitchB-Vlan-interface200]ip address 10.10.10.2 255.255.255.0
 
【SwitchC相关配置】
1.      创建(进入)vlan30
[SwitchC] vlan 30
2.      将E0/1加入到vlan30
[SwitchC-vlan30]port Ethernet 0/1

3.      实际当中一般将上行端口设置成trunk属性,答应vlan透传
[SwitchC-GigabitEthernet1/1]port link-type trunk
4.      答应所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值
[SwitchC-GigabitEthernet1/1]port trunk permit vlan 30

3         测试验证

1.      PC1、PC2和PC3都能够正确的获取IP地址和网关
2.      PC1、PC2和PC3都能够PING通自己的网关及DHCP server

?