一个使用组播和Qos的华为路由器配置

3/1/2008来源:华为网络人气:7290

multicast routing-enable                        

#

interface Ethernet4/2/0                      

description neiwang                   

ip address 172.20.1.1 255.255.255.0                                   

pim sm      

#

interface Ethernet4/2/1                      

description to-gehua                    

ip address 172.20.254.1 255.255.255.248                                       

qos car outbound acl 3012 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               

scard    

qos car outbound acl 3000 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               

scard    

qos car outbound acl 3001 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               


scard    

qos car outbound acl 3002 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               

scard    

qos car outbound acl 3003 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               

scard    

qos car outbound acl 3005 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               

scard    

qos car outbound acl 3006 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               

scard    

qos car outbound acl 3007 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               


scard    

qos car outbound acl 3008 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               

scard    

qos car outbound acl 3009 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               

scard    

qos car outbound acl 3010 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               

scard    

qos car outbound acl 3011 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               

scard    

qos car outbound acl 3004 cir 8000000 cbs 8000000 ebs 8000000 green pass red di                                                                               

scard    


pim sm      

#

interface Ethernet4/2/2                      

description wuxian                  

ip address 172.20.254.90                      

ip address 172.20.14.22 255.255.255.248 sub                                           

ip address 172.20.14.38 255.255.255.248 sub                                           

ip address 172.20.254.98 255.255.255.248 sub                                            

pim sm      

#

interface GigabitEthernet4/0/0                             

pim sm      

#

interface NULL0              

#

interface LoopBack0                  

ip address 172.20.2.1 255.255.255.255                                     

pim sm      

#

acl number 3000              

rule 0 permit ip source 172.20.1.0 0.0.0.255 destination 172.20.10.0 0.0.0.16                                                                             


rule 1 deny ip              

acl number 3001              

rule 0 permit ip source 172.20.1.0 0.0.0.255 destination 172.20.11.0 0.0.0.16                                                                             

rule 1 deny ip              

acl number 3002              

rule 0 permit ip source 172.20.1.0 0.0.0.255 destination 172.20.12.0 0.0.0.16                                                                             

rule 1 deny ip              

acl number 3003              

rule 0 permit ip source 172.20.1.0 0.0.0.255 destination 172.20.13.0 0.0.0.16                                                                             

rule 1 deny ip              

acl number 3004              

rule 0 permit ip source 172.20.1.0 0.0.0.255 destination 172.20.14.0 0.0.0.16                                                                             


rule 1 deny ip              

acl number 3005              

rule 0 permit ip source 172.20.1.0 0.0.0.255 destination 172.20.15.0 0.0.0.16                                                                             

rule 1 deny ip              

acl number 3006              

rule 0 permit ip source 172.20.1.0 0.0.0.255 destination 172.20.16.0 0.0.                                                                        

rule 1 deny ip              

acl number 3007              

rule 0 permit ip source 172.20.1.0 0.0.0.255 destination 172.20.17.0 0.0.0.16                                                                             

rule 1 deny ip              

acl number 3008              

rule 0 permit ip source 172.20.1.0 0.0.0.255 destination 172.20.18.0 0.0.0.16                                                                             


rule 1 deny ip              

acl number 3009              

rule 0 permit ip source 172.20.1.0 0.0.0.255 destination 172.20.19.0 0.0.0.16                                                                             

rule 1 deny ip              

acl number 3010              

rule 0 permit ip source 172.20.1.0 0.0.0.255 destination 172.20.20.0 0.0.0.16                                                                             

rule 1 deny ip              

acl number 3011              

rule 0 permit ip source 172.20.1.0 0.0.0.2                                         

rule 1 deny ip              

acl number 3012              

rule 0 permit ip source 172.20.1.0 0.0.0.255 destination 172.20.21.0 0.0.0.16 

rule 1 deny ip

#

rip

#

pim

c-bsr Ethernet4/2/1 24

c-rp Ethernet4/2/1

#

ip route-static 0.0.0.0 0.0.0.0 172.20.254.2 PReference 60

ip route-static 172.20.20.0 255.255.255.0 172.20.254.92 preference 60

#

snmp-agent

snmp-agent local-engineid 800007DB0300E0FC57516B

snmp-agent community read  hjbhj

snmp-agent community write  hjzczx

snmp-agent sys-info version all

#

user-interface con 0

user-interface aux 0

user-interface vty 0 4

set authentication passWord simple huawei


#