Firefox 3.0.1并不破坏插件兼容性

7/21/2008来源:Firefox浏览器人气:6681

开发者Basil Hashem称本来在Firefox3.0下运行良好的插件在Firefox 3.0.1下通不过兼容性检查主要是因为是插件作者的原因,正确的兼容性标识应该是:“2.0 to 3.0.*”。意味着从Firefox2.0以后到所有Firefox3.0的相关版本都可以兼容。

但是有些作者将后面的maxVersion写成了3.0,于是当Firefox3.0升级到Firefox3.0.1时,有些插件因为这种原因就不能使用了。所以他建议插件作者使用“3.0.*”作为后面的maxVersion标识。

AMO上大部分的插件都是以“3.0.*”结尾的,所以可以放心使用。另外,如果遇到这个问题,能通知一下插件作者最好了:)

不过我倒是没有遇到这些问题,升级一切顺利。真的要有问题,解开安装包后修改install.rdf中的maxVersion,帮作者改成3.0.*吧:)