Apache连接PHP后无法启动问题解决思路

8/31/2015来源:PHP技巧人气:1269

Apache连接php后无法启动问题解决思路

问题:apache之前正常,连接配置完PHP后无法启动,用apache Test Configration测试后报错形式为:Cannot load D:/php/php5apache2_2.dll into server(或者php5apache2_4.dll)我个人的解决轨迹是这样的:1 先查看一下配置时的路径,拼写是否有误,没找出错2 之前用apache一直没有问题,所以觉得是PHP下载的版本不对,我一开始下载的是5.6,里边的模块文件是php5apache2_4.dll,所以认为PHP也没有问题,百度一搜发现有可能是缺少正确的VC库版本3 然后,我查看了一下php包(最好上官网下载)的文件,文件名中有提示是VC9(好像是,这个包我后来也删掉了,不过这个不重要),然后搜到下边这段:php5.5使用的编译器是vc11,php5.4和php5.3的是vc9,php5.2是vc6。同时还要注意是x86版本,还是x64版本。目前只有php5.5提供x64版本,其他都只有x86版本。apache.org下载的Apache都是vc6版本,否则就根据不同文件说明安装不同的运行库。vc11运行库x86/x64版本:http://www.microsoft.com/en-us/download/details.aspx?id=30679vc10运行库x86版本:http://www.microsoft.com/en-us/download/details.aspx?id=5555vc10运行库x64版本:http://www.microsoft.com/en-us/download/details.aspx?id=14632vc9运行库x86版本:http://www.microsoft.com/en-us/download/details.aspx?id=5582vc9运行库x64版本:http://www.microsoft.com/en-us/download/details.aspx?id=15336但是,我下载安装好VC库之后,以为可以但,但依旧报同样的错...4 我把下载的VC库删掉,又换了个下载地址试了下,依旧不行,又下载VC10依旧也不行,妈的!5 那么,肯定不是VC库的问题,也不是apache的问题,那么还是PHP的问题。于是,我上官网又下载了一个低版本的PHP5.3.5,解压后发现这个版本的模块文件变成了php5apache2_2.dll,而5.6版本的是php5apache2_4.dll,接着又下载了一个PHP版本,发现里面没有模块文件,坑!6 所以我判断可能是这个文件的问题,于是换5.3.5这个版本,尼马,成功了!!!7 喜悦之余查看之前打开的一个网页,往下一滚,居然刚好有解决这个问题的描述:  如果Apache/PHP还无法启动,那最可能是php5_module模块的问题:  1、Apache2.0对应的PHP模块为 php5apache2.dll  2、Apache2.2对应的PHP模块为 php5apache2_2.dll  3、Apache2.4对应的PHP模块为 php5apache2_4.dll  换句话说,根据php5_module模块,可以知道当前版本php支持哪种Apache  所以,Apache/PHP的搭配有以下几种情况:  1、php5.2支持Apache2.0和Apache2.2;  2、php5.3、php5.4同时支持Apache2.2和Apache2.4;  3、php5.5只支持Apache2.48 汗啊,只是再多滚一屏就可以更早解决问题了,切记不能懒啊..